summaryrefslogtreecommitdiffstats
path: root/toolchain/uClibc/uclibc.mk
diff options
context:
space:
mode:
authorNigel Kukard2008-03-29 17:23:16 +0100
committerNigel Kukard2008-03-29 17:23:16 +0100
commit9a193dfbf00928913d4331be7b9d07396421e41c (patch)
tree2cc057833b17d2f5ac5f906b9d8baafe73b11219 /toolchain/uClibc/uclibc.mk
parentAdd some robustness to linux configuration (diff)
downloadbuildroot-9a193dfbf00928913d4331be7b9d07396421e41c.tar.gz
buildroot-9a193dfbf00928913d4331be7b9d07396421e41c.tar.xz
buildroot-9a193dfbf00928913d4331be7b9d07396421e41c.zip
* Fixed uClibc sub-x86 arch selection
Diffstat (limited to 'toolchain/uClibc/uclibc.mk')
-rw-r--r--toolchain/uClibc/uclibc.mk26
1 files changed, 25 insertions, 1 deletions
diff --git a/toolchain/uClibc/uclibc.mk b/toolchain/uClibc/uclibc.mk
index b9f73bcd0..21411ce6a 100644
--- a/toolchain/uClibc/uclibc.mk
+++ b/toolchain/uClibc/uclibc.mk
@@ -353,7 +353,31 @@ ifeq ($(BR2_x86_i486),y)
endif
ifeq ($(BR2_x86_i586),y)
$(SED) 's,# CONFIG_586 is not set,CONFIG_586=y,g' $(UCLIBC_DIR)/.oldconfig
-endif
+endif
+ifeq ($(BR2_x86_pentium_mmx),y)
+ $(SED) 's,# CONFIG_586MMX is not set,CONFIG_586MMX=y,g' $(UCLIBC_DIR)/.oldconfig
+endif
+ifeq ($(BR2_x86_pentium2),y)
+ $(SED) 's,# CONFIG_PENTIUMII is not set,CONFIG_PENTIUMII=y,g' $(UCLIBC_DIR)/.oldconfig
+endif
+ifeq ($(BR2_x86_pentium3),y)
+ $(SED) 's,# CONFIG_PENTIUMIII is not set,CONFIG_PENTIUMIII=y,g' $(UCLIBC_DIR)/.oldconfig
+endif
+ifeq ($(BR2_x86_pentium4),y)
+ $(SED) 's,# CONFIG_PENTIUM4 is not set,CONFIG_PENTIUM4=y,g' $(UCLIBC_DIR)/.oldconfig
+endif
+ifeq ($(BR2_x86_pentium_m),y)
+ $(SED) 's,# CONFIG_PENTIUM4 is not set,CONFIG_PENTIUM4=y,g' $(UCLIBC_DIR)/.oldconfig
+endif
+ifeq ($(BR2_x86_pentiumpro),y)
+ $(SED) 's,# CONFIG_PENTIUM4 is not set,CONFIG_PENTIUM4=y,g' $(UCLIBC_DIR)/.oldconfig
+endif
+ifeq ($(BR2_x86_nocona),y)
+ $(SED) 's,# CONFIG_PENTIUM4 is not set,CONFIG_PENTIUM4=y,g' $(UCLIBC_DIR)/.oldconfig
+endif
+ifeq ($(BR2_x86_core2),y)
+ $(SED) 's,# CONFIG_PENTIUM4 is not set,CONFIG_PENTIUM4=y,g' $(UCLIBC_DIR)/.oldconfig
+endif
ifeq ($(BR2_x86_i686),y)
$(SED) 's,# CONFIG_686 is not set,CONFIG_686=y,g' $(UCLIBC_DIR)/.oldconfig
endif