summaryrefslogtreecommitdiffstats
path: root/toolchain
diff options
context:
space:
mode:
authorPeter Korsgaard2008-06-06 14:49:53 +0200
committerPeter Korsgaard2008-06-06 14:49:53 +0200
commit197ab1cef220e7beedccdc1ae9f195e0ceaaf538 (patch)
tree9360e817bde8e7c076f035f9d0edf26a62695531 /toolchain
parenttslib: fix inputattach patch typos (diff)
downloadbuildroot-197ab1cef220e7beedccdc1ae9f195e0ceaaf538.tar.gz
buildroot-197ab1cef220e7beedccdc1ae9f195e0ceaaf538.tar.xz
buildroot-197ab1cef220e7beedccdc1ae9f195e0ceaaf538.zip
toolchain: also use arch/tune/abi options when softfloat is enabled
The ifeq/endif nesting was wrong, so arch/tune/abi options where only set in the non-softfloat case.
Diffstat (limited to 'toolchain')
-rw-r--r--toolchain/gcc/Makefile.in3
1 files changed, 2 insertions, 1 deletions
diff --git a/toolchain/gcc/Makefile.in b/toolchain/gcc/Makefile.in
index 1ada6dfae..b323f326e 100644
--- a/toolchain/gcc/Makefile.in
+++ b/toolchain/gcc/Makefile.in
@@ -50,6 +50,8 @@ else # no softfloat support
SOFT_FLOAT_CONFIG_OPTION:=
TARGET_SOFT_FLOAT:=
ARCH_FPU_SUFFIX:=
+endif
+
# some additional defaults
ifneq ($(strip $(subst ",,$(BR2_GCC_TARGET_ARCH))),)
# ")))
@@ -63,7 +65,6 @@ ifneq ($(strip $(subst ",,$(BR2_GCC_TARGET_ABI))),)
# ")))
GCC_WITH_ABI:=--with-abi=$(BR2_GCC_TARGET_ABI)
endif
-endif
# AVR32 GCC configuration
ifeq ($(strip $(BR2_avr32)),y)