summaryrefslogtreecommitdiffstats
path: root/toolchain
diff options
context:
space:
mode:
authorPeter Korsgaard2012-03-30 00:22:47 +0200
committerPeter Korsgaard2012-03-30 00:22:47 +0200
commit1b7f5285fbf6b03c14d48d614ae3ade91868f954 (patch)
tree48a2e2f9db74977e452d1737791afbc9f193fd18 /toolchain
parentpsmisc: bump to version 22.16 (diff)
downloadbuildroot-1b7f5285fbf6b03c14d48d614ae3ade91868f954.tar.gz
buildroot-1b7f5285fbf6b03c14d48d614ae3ade91868f954.tar.xz
buildroot-1b7f5285fbf6b03c14d48d614ae3ade91868f954.zip
toolchain: add linaro 2012.03 external ARM toolchain
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'toolchain')
-rw-r--r--toolchain/toolchain-external/Config.in15
-rw-r--r--toolchain/toolchain-external/ext-tool.mk3
2 files changed, 18 insertions, 0 deletions
diff --git a/toolchain/toolchain-external/Config.in b/toolchain/toolchain-external/Config.in
index 014bfc583..991684fc0 100644
--- a/toolchain/toolchain-external/Config.in
+++ b/toolchain/toolchain-external/Config.in
@@ -3,6 +3,20 @@ if BR2_TOOLCHAIN_EXTERNAL
choice
prompt "Toolchain"
+config BR2_TOOLCHAIN_EXTERNAL_LINARO_2012_03
+ bool "Linaro 2012.03"
+ depends on BR2_arm
+ depends on BR2_cortex_a8 || BR2_cortex_a9
+ select BR2_TOOLCHAIN_EXTERNAL_GLIBC
+ select BR2_INSTALL_LIBSTDCPP
+ help
+ Linaro toolchain for the ARM architecture. It uses Linaro
+ GCC 2012.03 (based on gcc 4.6), Linaro GDB 2012.03, eglibc
+ 2.13. It generates code that runs on all Cortex-A profile
+ devices, but tuned for the Cortex-A9. The code generated is
+ Thumb 2, with the softfp calling convention, and uses the
+ VFPv3-D16 FPU instructions.
+
config BR2_TOOLCHAIN_EXTERNAL_LINARO_2012_02
bool "Linaro 2012.02"
depends on BR2_arm
@@ -484,6 +498,7 @@ config BR2_TOOLCHAIN_EXTERNAL_PREFIX
string
default "arm-linux-gnueabi" if BR2_TOOLCHAIN_EXTERNAL_LINARO_2012_01
default "arm-linux-gnueabi" if BR2_TOOLCHAIN_EXTERNAL_LINARO_2012_02
+ default "arm-linux-gnueabi" if BR2_TOOLCHAIN_EXTERNAL_LINARO_2012_03
default "arm-none-linux-gnueabi" if BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_ARM2009Q3
default "arm-none-linux-gnueabi" if BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_ARM2010Q1
default "arm-none-linux-gnueabi" if BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_ARM201009
diff --git a/toolchain/toolchain-external/ext-tool.mk b/toolchain/toolchain-external/ext-tool.mk
index 51bce913b..0a997a593 100644
--- a/toolchain/toolchain-external/ext-tool.mk
+++ b/toolchain/toolchain-external/ext-tool.mk
@@ -197,6 +197,9 @@ TOOLCHAIN_EXTERNAL_SOURCE=gcc-linaro-arm-linux-gnueabi-2012.01-20120125_linux.ta
else ifeq ($(BR2_TOOLCHAIN_EXTERNAL_LINARO_2012_02),y)
TOOLCHAIN_EXTERNAL_SITE=http://launchpad.net/linaro-toolchain-binaries/trunk/2012.02/+download/
TOOLCHAIN_EXTERNAL_SOURCE=gcc-linaro-arm-linux-gnueabi-2012.02-20120222_linux.tar.bz2
+else ifeq ($(BR2_TOOLCHAIN_EXTERNAL_LINARO_2012_03),y)
+TOOLCHAIN_EXTERNAL_SITE=http://launchpad.net/linaro-toolchain-binaries/trunk/2012.03/+download/
+TOOLCHAIN_EXTERNAL_SOURCE=gcc-linaro-arm-linux-gnueabi-2012.03-20120326_linux.tar.bz2
else ifeq ($(BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_MIPS44),y)
TOOLCHAIN_EXTERNAL_SITE=http://sourcery.mentor.com/sgpp/lite/mips/portal/package7401/public/mips-linux-gnu/
TOOLCHAIN_EXTERNAL_SOURCE=mips-4.4-303-mips-linux-gnu-i686-pc-linux-gnu.tar.bz2