summaryrefslogtreecommitdiffstats
path: root/toolchain
diff options
context:
space:
mode:
authorThomas Petazzoni2012-04-17 06:45:30 +0200
committerPeter Korsgaard2012-04-25 09:00:42 +0200
commit2b563d481fbeeabc1c904e2398ec99a453faf6f2 (patch)
treed9b48b59610f605bc062721b9cd96e91022aa086 /toolchain
parentgcc: remove unused ARCH_FPU_SUFFIX (diff)
downloadbuildroot-2b563d481fbeeabc1c904e2398ec99a453faf6f2.tar.gz
buildroot-2b563d481fbeeabc1c904e2398ec99a453faf6f2.tar.xz
buildroot-2b563d481fbeeabc1c904e2398ec99a453faf6f2.zip
gcc: move version/snap variables to gcc-uclibc-4.x.mk
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'toolchain')
-rw-r--r--toolchain/gcc/Makefile.in6
-rw-r--r--toolchain/gcc/gcc-uclibc-4.x.mk8
2 files changed, 8 insertions, 6 deletions
diff --git a/toolchain/gcc/Makefile.in b/toolchain/gcc/Makefile.in
index c3f457627..3e82a324b 100644
--- a/toolchain/gcc/Makefile.in
+++ b/toolchain/gcc/Makefile.in
@@ -3,15 +3,9 @@
# So include them in this file and arrange to include it
# soon after invoking make from the top level.
-GCC_VERSION:=$(call qstrip,$(BR2_GCC_VERSION))
TARGET_OPTIMIZATION:=$(call qstrip,$(BR2_TARGET_OPTIMIZATION))
EXTRA_GCC_CONFIG_OPTIONS:=$(call qstrip,$(BR2_EXTRA_GCC_CONFIG_OPTIONS))
-ifeq ($(call qstrip,$(BR2_GCC_VERSION_SNAP)),y)
-GCC_SNAP_DATE:=$(call qstrip,$(BR2_GCC_SNAP_DATE))
-else
-GCC_SNAP_DATE:=
-endif
ifeq ($(BR2_SOFT_FLOAT),y)
SOFT_FLOAT_CONFIG_OPTION:=--with-float=soft
diff --git a/toolchain/gcc/gcc-uclibc-4.x.mk b/toolchain/gcc/gcc-uclibc-4.x.mk
index 212660c7d..3d0228d11 100644
--- a/toolchain/gcc/gcc-uclibc-4.x.mk
+++ b/toolchain/gcc/gcc-uclibc-4.x.mk
@@ -17,6 +17,14 @@
# along with this program; if not, write to the Free Software
# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
+GCC_VERSION:=$(call qstrip,$(BR2_GCC_VERSION))
+
+ifeq ($(BR2_GCC_VERSION_SNAP),y)
+GCC_SNAP_DATE:=$(call qstrip,$(BR2_GCC_SNAP_DATE))
+else
+GCC_SNAP_DATE:=
+endif
+
ifneq ($(GCC_SNAP_DATE),)
GCC_SITE:=ftp://sources.redhat.com/pub/gcc/snapshots/$(GCC_VERSION)
else ifeq ($(findstring avr32,$(GCC_VERSION)),avr32)