summaryrefslogtreecommitdiffstats
path: root/toolchain
diff options
context:
space:
mode:
authorBernhard Reutner-Fischer2007-02-04 17:34:56 +0100
committerBernhard Reutner-Fischer2007-02-04 17:34:56 +0100
commit3c1f00b21a11a861ffee0ef801dc57b50b0639c1 (patch)
tree00c2393e0c177dd2dc4eec833ca30b8d5b818488 /toolchain
parent- propagate BR2_ARM_EABI setting down to LINUX26_KCONFIG (diff)
downloadbuildroot-3c1f00b21a11a861ffee0ef801dc57b50b0639c1.tar.gz
buildroot-3c1f00b21a11a861ffee0ef801dc57b50b0639c1.tar.xz
buildroot-3c1f00b21a11a861ffee0ef801dc57b50b0639c1.zip
- avoid spurious rebuilds. Thanks to janlana, closes #1191
- provide a syslinux-source target while at it
Diffstat (limited to 'toolchain')
-rw-r--r--toolchain/gcc/gcc-uclibc-3.x.mk5
1 files changed, 3 insertions, 2 deletions
diff --git a/toolchain/gcc/gcc-uclibc-3.x.mk b/toolchain/gcc/gcc-uclibc-3.x.mk
index 9975dd6f2..8155b55bf 100644
--- a/toolchain/gcc/gcc-uclibc-3.x.mk
+++ b/toolchain/gcc/gcc-uclibc-3.x.mk
@@ -292,7 +292,7 @@ endif
#
touch $@
-gcc-target-libs: $(GCC_BUILD_DIR2)/.installed
+$(GCC_BUILD_DIR2)/.libs_installed: $(GCC_BUILD_DIR2)/.installed
ifeq ($(BR2_GCC_SHARED_LIBGCC),y)
# These are in /lib, so...
rm -rf $(TARGET_DIR)/usr/lib/libgcc_s*.so*
@@ -311,7 +311,8 @@ ifeq ($(BR2_INSTALL_LIBGCJ),y)
endif
gcc: uclibc-configured binutils gcc_initial $(LIBFLOAT_TARGET) uclibc \
- $(GCC_BUILD_DIR2)/.installed gcc-target-libs $(GCC_TARGETS)
+ $(GCC_BUILD_DIR2)/.installed $(GCC_BUILD_DIR2)/.libs_installed \
+ $(GCC_TARGETS)
gcc-source: $(DL_DIR)/$(GCC_SOURCE)