summaryrefslogtreecommitdiffstats
path: root/toolchain
diff options
context:
space:
mode:
authorMike Frysinger2006-06-30 03:25:51 +0200
committerMike Frysinger2006-06-30 03:25:51 +0200
commit5675a37772d5e5b8e4e808e42fc61761552c14d6 (patch)
tree1da2cf5e09976166d6f538e2da7db140396e6173 /toolchain
parentbackport some fixes from 4.2 patchset to fix __global_locale error (diff)
downloadbuildroot-5675a37772d5e5b8e4e808e42fc61761552c14d6.tar.gz
buildroot-5675a37772d5e5b8e4e808e42fc61761552c14d6.tar.xz
buildroot-5675a37772d5e5b8e4e808e42fc61761552c14d6.zip
some fixes from Gentoo
Diffstat (limited to 'toolchain')
-rw-r--r--toolchain/gcc/4.2/300-libstdc++-pic.patch18
1 files changed, 11 insertions, 7 deletions
diff --git a/toolchain/gcc/4.2/300-libstdc++-pic.patch b/toolchain/gcc/4.2/300-libstdc++-pic.patch
index 89d03a85e..560bcb237 100644
--- a/toolchain/gcc/4.2/300-libstdc++-pic.patch
+++ b/toolchain/gcc/4.2/300-libstdc++-pic.patch
@@ -1,20 +1,22 @@
# DP: Build and install libstdc++_pic.a library.
---- gcc-4.1.0/libstdc++-v3/src/Makefile.am 2004-11-15 17:33:05.000000000 -0600
-+++ gcc-4.1.0-patched/libstdc++-v3/src/Makefile.am 2005-04-25 20:05:59.186930896 -0500
-@@ -214,6 +214,10 @@
+--- gcc/libstdc++-v3/src/Makefile.am
++++ gcc/libstdc++-v3/src/Makefile.am
+@@ -214,6 +214,12 @@
$(OPT_LDFLAGS) $(SECTION_LDFLAGS) $(AM_CXXFLAGS) $(LDFLAGS) -o $@
+install-exec-local:
++ifeq ($(enable_shared),yes)
+ $(AR) cru libstdc++_pic.a .libs/*.o $(top_builddir)/libsupc++/*.o
+ $(INSTALL_DATA) libstdc++_pic.a $(DESTDIR)$(toolexeclibdir)
++endif
+
# Added bits to build debug library.
if GLIBCXX_BUILD_DEBUG
all-local: build_debug
---- gcc-4.1.0/libstdc++-v3/src/Makefile.in 2005-04-11 19:13:08.000000000 -0500
-+++ gcc-4.1.0-patched/libstdc++-v3/src/Makefile.in 2005-04-25 20:12:33.284316275 -0500
+--- gcc/libstdc++-v3/src/Makefile.in
++++ gcc/libstdc++-v3/src/Makefile.in
@@ -627,7 +627,7 @@
install-data-am: install-data-local
@@ -32,14 +34,16 @@
install-exec-am install-info install-info-am install-man \
install-strip install-toolexeclibLTLIBRARIES installcheck \
installcheck-am installdirs maintainer-clean \
-@@ -745,6 +746,11 @@
+@@ -743,6 +743,13 @@
install_debug:
(cd ${debugdir} && $(MAKE) \
toolexeclibdir=$(glibcxx_toolexeclibdir)/debug install)
+
+install-exec-local:
-+ $(AR) cru libstdc++_pic.a .libs/*.o $(top_builddir)/libsupc++/*.o
++ifeq ($(enable_shared),yes)
++ $(AR) cru libstdc++_pic.a *.o $(top_builddir)/libsupc++/*.o
+ $(INSTALL_DATA) libstdc++_pic.a $(DESTDIR)$(toolexeclibdir)
++endif
+
# Tell versions [3.59,3.63) of GNU make to not export all variables.
# Otherwise a system limit (for SysV at least) may be exceeded.