summaryrefslogtreecommitdiffstats
path: root/toolchain
diff options
context:
space:
mode:
authorPeter Korsgaard2006-10-26 17:15:08 +0200
committerPeter Korsgaard2006-10-26 17:15:08 +0200
commit80a224bea1bd7727ec6089989c36859e77f71d36 (patch)
treef8703aeeff73e2ae38c3cb9594dfcccd8d0d609e /toolchain
parentBump to upstream v1.2.2 (diff)
downloadbuildroot-80a224bea1bd7727ec6089989c36859e77f71d36.tar.gz
buildroot-80a224bea1bd7727ec6089989c36859e77f71d36.tar.xz
buildroot-80a224bea1bd7727ec6089989c36859e77f71d36.zip
Fix missing libgcc_s.so.1 with BR2_GCC_SHARED_LIBGCC
Diffstat (limited to 'toolchain')
-rw-r--r--toolchain/gcc/gcc-uclibc-3.x.mk7
1 files changed, 3 insertions, 4 deletions
diff --git a/toolchain/gcc/gcc-uclibc-3.x.mk b/toolchain/gcc/gcc-uclibc-3.x.mk
index 1522ce592..4b05fee5f 100644
--- a/toolchain/gcc/gcc-uclibc-3.x.mk
+++ b/toolchain/gcc/gcc-uclibc-3.x.mk
@@ -250,12 +250,11 @@ endif
#
# Ok... that's enough of that.
#
- touch $(GCC_BUILD_DIR2)/.installed
-
-$(TARGET_DIR)/lib/libgcc_s.so.1: $(GCC_BUILD_DIR2)/.installed
+ifeq ($(BR2_GCC_SHARED_LIBGCC),y)
# These are in /lib, so...
rm -rf $(TARGET_DIR)/usr/lib/libgcc_s*.so*
-cp -a $(STAGING_DIR)/$(REAL_GNU_TARGET_NAME)/lib/libgcc_s* $(TARGET_DIR)/lib/
+endif
ifeq ($(BR2_INSTALL_LIBSTDCPP),y)
-cp -a $(STAGING_DIR)/lib/libstdc++.so* $(TARGET_DIR)/lib/
endif
@@ -267,7 +266,7 @@ ifeq ($(BR2_INSTALL_LIBGCJ),y)
-cp -a $(STAGING_DIR)/usr/lib/security/libgcj.security $(TARGET_DIR)/usr/lib/security/
-cp -a $(STAGING_DIR)/usr/lib/security/classpath.security $(TARGET_DIR)/usr/lib/security/
endif
- touch -c $(TARGET_DIR)/lib/libgcc_s.so.1
+ touch $(GCC_BUILD_DIR2)/.installed
gcc: uclibc-configured binutils gcc_initial $(LIBFLOAT_TARGET) uclibc \
$(GCC_BUILD_DIR2)/.installed $(GCC_TARGETS)