summaryrefslogtreecommitdiffstats
path: root/toolchain
diff options
context:
space:
mode:
authorUlf Samuelsson2007-09-03 08:10:01 +0200
committerUlf Samuelsson2007-09-03 08:10:01 +0200
commit82d52e8d84ab2d54bcc23cb6893517055c1ad5c3 (patch)
treefe33fed0a74643b18d282f57ffbb6df69c4a7eb9 /toolchain
parent- adjust list of needed applets (diff)
downloadbuildroot-82d52e8d84ab2d54bcc23cb6893517055c1ad5c3.tar.gz
buildroot-82d52e8d84ab2d54bcc23cb6893517055c1ad5c3.tar.xz
buildroot-82d52e8d84ab2d54bcc23cb6893517055c1ad5c3.zip
Cleanup handling of gccbug script
Diffstat (limited to 'toolchain')
-rw-r--r--toolchain/gcc/gcc-uclibc-3.x.mk2
-rw-r--r--toolchain/gcc/gcc-uclibc-4.x.mk4
2 files changed, 1 insertions, 5 deletions
diff --git a/toolchain/gcc/gcc-uclibc-3.x.mk b/toolchain/gcc/gcc-uclibc-3.x.mk
index 1dff9ebed..a21e9a0ad 100644
--- a/toolchain/gcc/gcc-uclibc-3.x.mk
+++ b/toolchain/gcc/gcc-uclibc-3.x.mk
@@ -282,7 +282,7 @@ $(GCC_BUILD_DIR2)/.installed: $(GCC_BUILD_DIR2)/.compiled
fi
# Strip the host binaries
ifeq ($(GCC_STRIP_HOST_BINARIES),true)
- -strip --strip-all -R .note -R .comment $(STAGING_DIR)/usr/bin/*
+ strip --strip-all -R .note -R .comment $(filter-out -gccbug,$(wildcard $(STAGING_DIR)/usr/bin/$(REAL_GNU_TARGET_NAME)-*))
endif
# Make sure we have 'cc'.
if [ ! -e $(STAGING_DIR)/usr/bin/$(REAL_GNU_TARGET_NAME)-cc ]; then \
diff --git a/toolchain/gcc/gcc-uclibc-4.x.mk b/toolchain/gcc/gcc-uclibc-4.x.mk
index a420c7fac..c6f9df056 100644
--- a/toolchain/gcc/gcc-uclibc-4.x.mk
+++ b/toolchain/gcc/gcc-uclibc-4.x.mk
@@ -288,13 +288,9 @@ $(GCC_BUILD_DIR2)/.installed: $(GCC_BUILD_DIR2)/.compiled
mv "$(STAGING_DIR)/lib64/"* "$(STAGING_DIR)/lib/"; \
rmdir "$(STAGING_DIR)/lib64"; \
fi
- # Move gcc bug reporting script out of path of real executables
- mv -f $(STAGING_DIR)/usr/bin/$(REAL_GNU_TARGET_NAME)-gccbug \
- $(STAGING_DIR)/usr/bin/$(GNU_TARGET_NAME)-gccbug
# Strip the host binaries
ifeq ($(GCC_STRIP_HOST_BINARIES),true)
strip --strip-all -R .note -R .comment $(filter-out -gccbug,$(wildcard $(STAGING_DIR)/usr/bin/$(REAL_GNU_TARGET_NAME)-*))
- -strip --strip-all -R .note -R .comment $(STAGING_DIR)/usr/bin/faked
endif
# Make sure we have 'cc'.
if [ ! -e $(STAGING_DIR)/usr/bin/$(REAL_GNU_TARGET_NAME)-cc ]; then \