summaryrefslogtreecommitdiffstats
path: root/toolchain
diff options
context:
space:
mode:
authorBernhard Reutner-Fischer2006-12-07 18:02:32 +0100
committerBernhard Reutner-Fischer2006-12-07 18:02:32 +0100
commit83fecd0e36b65d7d2f946fa0caa578160395a3c5 (patch)
tree9c5a5ee1c3e89d923e9324b5911e366c7ef73d7c /toolchain
parent- pass the target (kernel-) arch in. (diff)
downloadbuildroot-83fecd0e36b65d7d2f946fa0caa578160395a3c5.tar.gz
buildroot-83fecd0e36b65d7d2f946fa0caa578160395a3c5.tar.xz
buildroot-83fecd0e36b65d7d2f946fa0caa578160395a3c5.zip
- The sysroot requires an existing argument, so make sure that we did configure
uClibc properly before attempting to use it.
Diffstat (limited to 'toolchain')
-rw-r--r--toolchain/gcc/gcc-uclibc-3.x.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/toolchain/gcc/gcc-uclibc-3.x.mk b/toolchain/gcc/gcc-uclibc-3.x.mk
index 00471d71e..63cb908af 100644
--- a/toolchain/gcc/gcc-uclibc-3.x.mk
+++ b/toolchain/gcc/gcc-uclibc-3.x.mk
@@ -115,7 +115,7 @@ endif
# fixed, so we need to actually have working C library header files prior to
# the step or libgcc will not build...
-$(GCC_BUILD_DIR1)/.configured: $(GCC_DIR)/.patched
+$(GCC_BUILD_DIR1)/.configured: $(GCC_DIR)/.patched uclibc-configured
mkdir -p $(GCC_BUILD_DIR1)
(cd $(GCC_BUILD_DIR1); PATH=$(TARGET_PATH) \
CC="$(HOSTCC)" \