summaryrefslogtreecommitdiffstats
path: root/toolchain
diff options
context:
space:
mode:
authorBernhard Reutner-Fischer2007-08-22 11:22:07 +0200
committerBernhard Reutner-Fischer2007-08-22 11:22:07 +0200
commitaa81a0650884a0563e6dcb41dc15a5635a28481d (patch)
treead8e2788b9b644366128ded4f25bbe9e7e96b582 /toolchain
parent- use the correct host compiler (diff)
downloadbuildroot-aa81a0650884a0563e6dcb41dc15a5635a28481d.tar.gz
buildroot-aa81a0650884a0563e6dcb41dc15a5635a28481d.tar.xz
buildroot-aa81a0650884a0563e6dcb41dc15a5635a28481d.zip
- improve the way host prerequisites for "dependencies" are established
Diffstat (limited to 'toolchain')
-rw-r--r--toolchain/dependencies/dependencies.mk10
-rw-r--r--toolchain/kernel-headers/Config.in13
2 files changed, 7 insertions, 16 deletions
diff --git a/toolchain/dependencies/dependencies.mk b/toolchain/dependencies/dependencies.mk
index 4af03b8f8..d50042462 100644
--- a/toolchain/dependencies/dependencies.mk
+++ b/toolchain/dependencies/dependencies.mk
@@ -5,11 +5,15 @@
#
######################################################################
+DEPENDENCIES_HOST_PREREQ:=
ifeq ($(BR2_STRIP_sstrip),y)
-# XXX: this is a little bit ugly, yep.
-MAYBE_SSTRIP_HOST:=sstrip_host
+DEPENDENCIES_HOST_PREREQ+=sstrip_host
endif
-dependencies: host-sed host-lzma $(MAYBE_SSTRIP_HOST)
+ifneq ($(findstring y,$(BR2_KERNEL_HEADERS_LZMA)),)
+DEPENDENCIES_HOST_PREREQ+=host-lzma
+endif
+
+dependencies: host-sed $(DEPENDENCIES_HOST_PREREQ)
@HOSTCC="$(firstword $(HOSTCC))" MAKE="$(MAKE)" \
HOST_SED_DIR="$(HOST_SED_DIR)" \
$(TOPDIR)/toolchain/dependencies/dependencies.sh
diff --git a/toolchain/kernel-headers/Config.in b/toolchain/kernel-headers/Config.in
index 05587b809..808433a7a 100644
--- a/toolchain/kernel-headers/Config.in
+++ b/toolchain/kernel-headers/Config.in
@@ -74,19 +74,6 @@ config BR2_KERNEL_HEADERS_LZMA
initramfs filesystems. This requires the lzma
program in your development environment.
-config BR2_KERNEL_HEADERS_LZMA_INSTALL
- bool "Install lzma in /usr/local/bin (Requires system password) for sudo"
- depends on BR2_KERNEL_HEADERS_2_6_21 || BR2_KERNEL_HEADERS_2_6_22
- depends on BR2_KERNEL_HEADERS_LZMA
- default n
- help
- Install the lzma package in the /usr/local/bin directory
- so it is available for future builds. This requires sudo.
- If you do not know the system password you should not set
- this option. If you do not have lzma installed the only way
- to complete the linux build, ifl you apply the lzma patches
- is to have '$(STAGING_DIR)/usr/bin' in your path.
-
config BR2_KERNEL_HEADERS_PATCH_DIR
bool "Add additional headers from $(KERNEL_HEADERS_PATCH_DIR)"
default n