summaryrefslogtreecommitdiffstats
path: root/toolchain
diff options
context:
space:
mode:
authorBernhard Reutner-Fischer2007-09-01 19:11:24 +0200
committerBernhard Reutner-Fischer2007-09-01 19:11:24 +0200
commitac9348ac6d03230aba945138f926cfcb42361bc4 (patch)
treee1add45b835bf6b7c8304bc054f4c0305ef0bab9 /toolchain
parent- rephrase r19284 -- explicitely list base targets for World (diff)
downloadbuildroot-ac9348ac6d03230aba945138f926cfcb42361bc4.tar.gz
buildroot-ac9348ac6d03230aba945138f926cfcb42361bc4.tar.xz
buildroot-ac9348ac6d03230aba945138f926cfcb42361bc4.zip
- don't try to strip the gccbug script
Diffstat (limited to 'toolchain')
-rw-r--r--toolchain/gcc/gcc-uclibc-4.x.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/toolchain/gcc/gcc-uclibc-4.x.mk b/toolchain/gcc/gcc-uclibc-4.x.mk
index 1a3f80aad..2fad23fd7 100644
--- a/toolchain/gcc/gcc-uclibc-4.x.mk
+++ b/toolchain/gcc/gcc-uclibc-4.x.mk
@@ -291,7 +291,7 @@ $(GCC_BUILD_DIR2)/.installed: $(GCC_BUILD_DIR2)/.compiled
$(STAGING_DIR)/usr/bin/$(GNU_TARGET_NAME)-gccbug
# Strip the host binaries
ifeq ($(GCC_STRIP_HOST_BINARIES),true)
- -strip --strip-all -R .note -R .comment $(STAGING_DIR)/usr/bin/$(REAL_GNU_TARGET_NAME)-*
+ strip --strip-all -R .note -R .comment $(filter-out -gccbug,$(wildcard $(STAGING_DIR)/usr/bin/$(REAL_GNU_TARGET_NAME)-*))
-strip --strip-all -R .note -R .comment $(STAGING_DIR)/usr/bin/faked
endif
# Make sure we have 'cc'.