summaryrefslogtreecommitdiffstats
path: root/toolchain
diff options
context:
space:
mode:
authorEric Andersen2004-10-10 03:12:46 +0200
committerEric Andersen2004-10-10 03:12:46 +0200
commite697a16e5a17d4f024d25656ad035e92fbc3812a (patch)
treed67c0c6fb06a9d624c99d245470763e7c26332c9 /toolchain
parentFixup SOFT_FLOAT handling (diff)
downloadbuildroot-e697a16e5a17d4f024d25656ad035e92fbc3812a.tar.gz
buildroot-e697a16e5a17d4f024d25656ad035e92fbc3812a.tar.xz
buildroot-e697a16e5a17d4f024d25656ad035e92fbc3812a.zip
Andrew May writes:
A few more little ones. busybox fdisk with large files should be removed without large files. gdbtarget/gdb_client got mixed up in the Makefile.in. I think gdbtarget should have a depend on ncurses but I am not sure if it should go in the config or in the .mk. It may be nice to split out the server and client. uclibc.mk was checking BR2_SOFT_FLOAT for true not y.
Diffstat (limited to 'toolchain')
-rw-r--r--toolchain/gdb/Makefile.in4
-rw-r--r--toolchain/uClibc/uclibc.mk2
2 files changed, 3 insertions, 3 deletions
diff --git a/toolchain/gdb/Makefile.in b/toolchain/gdb/Makefile.in
index cdaf2ca0e..51a2ddb3d 100644
--- a/toolchain/gdb/Makefile.in
+++ b/toolchain/gdb/Makefile.in
@@ -2,9 +2,9 @@ GDB_VERSION:=$(strip $(subst ",, $(BR2_GDB_VERSION)))
#"
ifeq ($(strip $(BR2_PACKAGE_GDB)),y)
-TARGETS+=gdbclient
+TARGETS+=gdb_target
endif
ifeq ($(strip $(BR2_PACKAGE_GDB_SERVER)),y)
-TARGETS+=gdbserver gdb_target
+TARGETS+=gdbserver gdbclient
endif
diff --git a/toolchain/uClibc/uclibc.mk b/toolchain/uClibc/uclibc.mk
index ad8cbdfcc..1a4d515ec 100644
--- a/toolchain/uClibc/uclibc.mk
+++ b/toolchain/uClibc/uclibc.mk
@@ -66,7 +66,7 @@ else
$(SED) 's,^.*UCLIBC_HAS_LFS.*,UCLIBC_HAS_LFS=n,g' $(UCLIBC_DIR)/.config
endif
$(SED) 's,.*UCLIBC_HAS_WCHAR.*,UCLIBC_HAS_WCHAR=y,g' $(UCLIBC_DIR)/.config
-ifeq ($(BR2_SOFT_FLOAT),true)
+ifeq ($(BR2_SOFT_FLOAT),y)
$(SED) 's,.*HAS_FPU.*,HAS_FPU=n\nUCLIBC_HAS_FLOATS=y\nUCLIBC_HAS_SOFT_FLOAT=y,g' $(UCLIBC_DIR)/.config
endif
mkdir -p $(TOOL_BUILD_DIR)/uClibc_dev/usr/include