summaryrefslogtreecommitdiffstats
path: root/toolchain
diff options
context:
space:
mode:
authorMike Frysinger2005-09-22 05:06:33 +0200
committerMike Frysinger2005-09-22 05:06:33 +0200
commitfbd8ef5267e91ff5f5cf7b5ed97e15f51d4f63c4 (patch)
tree798ec230390e12932a9beb4960b34dd6440a0af6 /toolchain
parentpass --disable-multilib if user doesnt want multilib since some arches (like ... (diff)
downloadbuildroot-fbd8ef5267e91ff5f5cf7b5ed97e15f51d4f63c4.tar.gz
buildroot-fbd8ef5267e91ff5f5cf7b5ed97e15f51d4f63c4.tar.xz
buildroot-fbd8ef5267e91ff5f5cf7b5ed97e15f51d4f63c4.zip
if target arch installs into a lib64 dir, make sure we move the stuff to plain old lib
Diffstat (limited to 'toolchain')
-rw-r--r--toolchain/gcc/gcc-uclibc-3.x.mk7
1 files changed, 7 insertions, 0 deletions
diff --git a/toolchain/gcc/gcc-uclibc-3.x.mk b/toolchain/gcc/gcc-uclibc-3.x.mk
index ff08458c5..455b7d30c 100644
--- a/toolchain/gcc/gcc-uclibc-3.x.mk
+++ b/toolchain/gcc/gcc-uclibc-3.x.mk
@@ -176,6 +176,13 @@ $(GCC_BUILD_DIR2)/.compiled: $(GCC_BUILD_DIR2)/.configured
$(GCC_BUILD_DIR2)/.installed: $(GCC_BUILD_DIR2)/.compiled
PATH=$(TARGET_PATH) $(MAKE) -C $(GCC_BUILD_DIR2) install
+ if [ -d "$(STAGING_DIR)/lib64" ] ; then \
+ if [ ! -e "$(STAGING_DIR)/lib" ] ; then \
+ mkdir "$(STAGING_DIR)/lib" ; \
+ fi ; \
+ mv "$(STAGING_DIR)/lib64/"* "$(STAGING_DIR)/lib/" ; \
+ rmdir "$(STAGING_DIR)/lib64" ; \
+ fi
# Strip the host binaries
ifeq ($(GCC_STRIP_HOST_BINARIES),true)
-strip --strip-all -R .note -R .comment $(STAGING_DIR)/bin/*