summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--Config.in16
-rw-r--r--toolchain/kernel-headers/kernel-headers.mk12
-rw-r--r--toolchain/uClibc/uclibc.mk2
3 files changed, 27 insertions, 3 deletions
diff --git a/Config.in b/Config.in
index df5607f92..6d702a5a8 100644
--- a/Config.in
+++ b/Config.in
@@ -36,9 +36,18 @@ config BR2_mipsel
config BR2_powerpc
bool "powerpc"
-config BR2_sh
+config BR2_sh3
+ bool "sh3"
+
+config BR2_sh3eb
+ bool "sh3eb"
+
+config BR2_sh4
bool "sh4"
+config BR2_sh4eb
+ bool "sh4eb"
+
config BR2_sparc
bool "sparc"
@@ -54,7 +63,10 @@ config BR2_ARCH
default "mips" if BR2_mips
default "mipsel" if BR2_mipsel
default "powerpc" if BR2_powerpc
- default "sh4" if BR2_sh
+ default "sh3" if BR2_sh3
+ default "sh3eb" if BR2_sh3eb
+ default "sh4" if BR2_sh4
+ default "sh4eb" if BR2_sh4eb
default "sparc" if BR2_sparc
diff --git a/toolchain/kernel-headers/kernel-headers.mk b/toolchain/kernel-headers/kernel-headers.mk
index 0e77c4815..f5640a472 100644
--- a/toolchain/kernel-headers/kernel-headers.mk
+++ b/toolchain/kernel-headers/kernel-headers.mk
@@ -107,10 +107,22 @@ $(LINUX_HEADERS_DIR)/.configured: $(LINUX_HEADERS_DIR)/.patched
ln -fs arch-ebsa285 arch; fi); \
elif [ "$(ARCH)" = "cris" ];then \
(cd $(LINUX_HEADERS_DIR)/include; ln -fs asm-cris asm;) \
+ elif [ "$(ARCH)" = "sh3" ];then \
+ (cd $(LINUX_HEADERS_DIR)/include; ln -fs asm-sh asm; \
+ cd asm; \
+ ln -s cpu-sh3 cpu) \
+ elif [ "$(ARCH)" = "sh3eb" ];then \
+ (cd $(LINUX_HEADERS_DIR)/include; ln -fs asm-sh asm; \
+ cd asm; \
+ ln -s cpu-sh3 cpu) \
elif [ "$(ARCH)" = "sh4" ];then \
(cd $(LINUX_HEADERS_DIR)/include; ln -fs asm-sh asm; \
cd asm; \
ln -s cpu-sh4 cpu) \
+ elif [ "$(ARCH)" = "sh4eb" ];then \
+ (cd $(LINUX_HEADERS_DIR)/include; ln -fs asm-sh asm; \
+ cd asm; \
+ ln -s cpu-sh4 cpu) \
else \
(cd $(LINUX_HEADERS_DIR)/include; ln -fs asm-$(ARCH)$(NOMMU) asm;) \
fi
diff --git a/toolchain/uClibc/uclibc.mk b/toolchain/uClibc/uclibc.mk
index 256a04282..bff50fd5b 100644
--- a/toolchain/uClibc/uclibc.mk
+++ b/toolchain/uClibc/uclibc.mk
@@ -26,7 +26,7 @@ UCLIBC_TARGET_ARCH:=$(shell echo $(ARCH) | sed -e s'/-.*//' \
-e 's/ppc/powerpc/g' \
-e 's/v850.*/v850/g' \
-e 's/sh64/sh/' \
- -e 's/sh[234]/sh/' \
+ -e 's/sh[234].*/sh/' \
-e 's/mips.*/mips/' \
-e 's/mipsel.*/mips/' \
-e 's/cris.*/cris/' \