summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile10
1 files changed, 2 insertions, 8 deletions
diff --git a/Makefile b/Makefile
index fb1716638..7a0253b5b 100644
--- a/Makefile
+++ b/Makefile
@@ -88,14 +88,8 @@ dirs: $(DL_DIR) $(BUILD_DIR) $(STAGING_DIR)
# dependencies anywhere else
#
#############################################################
-$(DL_DIR):
- @mkdir -p $(DL_DIR)
-
-$(BUILD_DIR):
- @mkdir -p $(BUILD_DIR)
-
-$(TOOL_BUILD_DIR):
- @mkdir -p $(TOOL_BUILD_DIR)
+$(DL_DIR) $(BUILD_DIR) $(TOOL_BUILD_DIR):
+ @mkdir -p $@
$(STAGING_DIR):
@mkdir -p $(STAGING_DIR)/lib