summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorBernhard Reutner-Fischer2007-01-30 01:58:18 +0100
committerBernhard Reutner-Fischer2007-01-30 01:58:18 +0100
commit8d583fc01a44c04c1872b2c6144a221df30ee78d (patch)
tree5a1671d08b60c20443e08f0bc4fd682a6dc20185 /Makefile
parent- drop some stuff (diff)
downloadbuildroot-8d583fc01a44c04c1872b2c6144a221df30ee78d.tar.gz
buildroot-8d583fc01a44c04c1872b2c6144a221df30ee78d.tar.xz
buildroot-8d583fc01a44c04c1872b2c6144a221df30ee78d.zip
- generalize the menuconfig linux kernel support
- simplify toplevel mkdir rules a tiny bit
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile10
1 files changed, 2 insertions, 8 deletions
diff --git a/Makefile b/Makefile
index fb1716638..7a0253b5b 100644
--- a/Makefile
+++ b/Makefile
@@ -88,14 +88,8 @@ dirs: $(DL_DIR) $(BUILD_DIR) $(STAGING_DIR)
# dependencies anywhere else
#
#############################################################
-$(DL_DIR):
- @mkdir -p $(DL_DIR)
-
-$(BUILD_DIR):
- @mkdir -p $(BUILD_DIR)
-
-$(TOOL_BUILD_DIR):
- @mkdir -p $(TOOL_BUILD_DIR)
+$(DL_DIR) $(BUILD_DIR) $(TOOL_BUILD_DIR):
+ @mkdir -p $@
$(STAGING_DIR):
@mkdir -p $(STAGING_DIR)/lib