summaryrefslogtreecommitdiffstats
path: root/package/Makefile.in
diff options
context:
space:
mode:
Diffstat (limited to 'package/Makefile.in')
-rw-r--r--package/Makefile.in6
1 files changed, 3 insertions, 3 deletions
diff --git a/package/Makefile.in b/package/Makefile.in
index ca6dd1498..186329cf1 100644
--- a/package/Makefile.in
+++ b/package/Makefile.in
@@ -4,7 +4,7 @@ endif
ifndef HOSTMAKE
HOSTMAKE=$(MAKE)
endif
-HOSTMAKE :=$(shell $(CONFIG_SHELL) -c "which $(HOSTMAKE)" || type -p $(HOSTMAKE) || echo make)
+HOSTMAKE :=$(shell which $(HOSTMAKE) || type -p $(HOSTMAKE) || echo make)
MAKE1:=$(HOSTMAKE) -j1
MAKE:=$(HOSTMAKE) -j$(BR2_JLEVEL)
@@ -178,8 +178,8 @@ TARGET_STRIP=true -Not_stripping
STRIPCMD=$(TARGET_STRIP)
endif
INSTALL=/usr/bin/install
-FLEX:=$(shell $(CONFIG_SHELL) -c 'which flex || type -p flex')
-BISON:=$(shell $(CONFIG_SHELL) -c 'which bison || type -p bison')
+FLEX:=$(shell which flex || type -p flex)
+BISON:=$(shell which bison || type -p bison)
HOST_ARCH:=$(shell $(HOSTCC) -dumpmachine | sed -e s'/-.*//' \
-e 's/sparc.*/sparc/' \