summaryrefslogtreecommitdiffstats
path: root/package/Makefile.package.in
diff options
context:
space:
mode:
Diffstat (limited to 'package/Makefile.package.in')
-rw-r--r--package/Makefile.package.in16
1 files changed, 16 insertions, 0 deletions
diff --git a/package/Makefile.package.in b/package/Makefile.package.in
index 15fc08541..53cc8eba0 100644
--- a/package/Makefile.package.in
+++ b/package/Makefile.package.in
@@ -557,6 +557,22 @@ $(1)-clean: $(1)-uninstall \
$(1)-dirclean: $$($(2)_TARGET_DIRCLEAN)
+$(1)-clean-for-rebuild:
+ifneq ($$($(2)_OVERRIDE_SRCDIR),)
+ rm -f $$($(2)_TARGET_RSYNC)
+endif
+ rm -f $$($(2)_TARGET_BUILD)
+ rm -f $$($(2)_TARGET_INSTALL_STAGING)
+ rm -f $$($(2)_TARGET_INSTALL_TARGET)
+ rm -f $$($(2)_TARGET_INSTALL_HOST)
+
+$(1)-rebuild: $(1)-clean-for-rebuild all
+
+$(1)-clean-for-reconfigure: $(1)-clean-for-rebuild
+ rm -f $$($(2)_TARGET_CONFIGURE)
+
+$(1)-reconfigure: $(1)-clean-for-reconfigure all
+
# define the PKG variable for all targets, containing the
# uppercase package variable prefix
$$($(2)_TARGET_INSTALL_TARGET): PKG=$(2)