summaryrefslogtreecommitdiffstats
path: root/package/bzip2
diff options
context:
space:
mode:
Diffstat (limited to 'package/bzip2')
-rw-r--r--package/bzip2/bzip2.mk2
1 files changed, 2 insertions, 0 deletions
diff --git a/package/bzip2/bzip2.mk b/package/bzip2/bzip2.mk
index 39e183205..3f341ee7a 100644
--- a/package/bzip2/bzip2.mk
+++ b/package/bzip2/bzip2.mk
@@ -49,7 +49,9 @@ define BZIP2_INSTALL_STAGING_CMDS
)
endef
+# make sure busybox doesn't get overwritten by make install
define BZIP2_INSTALL_TARGET_CMDS
+ rm -f $(addprefix $(TARGET_DIR)/usr/bin/,bzip2 bunzip2 bzcat)
$(TARGET_MAKE_ENV) $(TARGET_CONFIGURE_OPTS) \
$(MAKE) PREFIX=$(TARGET_DIR)/usr -C $(@D) install
cp $(@D)/libbz2.so.$(BZIP2_SONAME) $(TARGET_DIR)/usr/lib/