summaryrefslogtreecommitdiffstats
path: root/package/ipset
diff options
context:
space:
mode:
Diffstat (limited to 'package/ipset')
-rw-r--r--package/ipset/Config.in12
-rw-r--r--package/ipset/ipset.mk13
2 files changed, 25 insertions, 0 deletions
diff --git a/package/ipset/Config.in b/package/ipset/Config.in
new file mode 100644
index 000000000..af16fa837
--- /dev/null
+++ b/package/ipset/Config.in
@@ -0,0 +1,12 @@
+config BR2_PACKAGE_IPSET
+ bool "ipset"
+ depends on BR2_LARGEFILE
+ select BR2_PACKAGE_LIBMNL
+ help
+ Utility to manage IP sets in the linux kernel.
+ Requires a patched kernel or version >=2.6.39.
+
+ http://ipset.netfilter.org/
+
+comment "ipset requires a toolchain with LARGEFILE support"
+ depends on !BR2_LARGEFILE
diff --git a/package/ipset/ipset.mk b/package/ipset/ipset.mk
new file mode 100644
index 000000000..9d901fc53
--- /dev/null
+++ b/package/ipset/ipset.mk
@@ -0,0 +1,13 @@
+#############################################################
+#
+# ipset
+#
+#############################################################
+
+IPSET_VERSION = 6.8
+IPSET_SOURCE = ipset-$(IPSET_VERSION).tar.bz2
+IPSET_SITE = http://ipset.netfilter.org
+IPSET_AUTORECONF = YES
+IPSET_DEPENDENCIES = libmnl host-pkg-config
+
+$(eval $(call AUTOTARGETS,package,ipset))