summaryrefslogtreecommitdiffstats
path: root/package/libroxml/libroxml-2.2.0-werror.patch
diff options
context:
space:
mode:
Diffstat (limited to 'package/libroxml/libroxml-2.2.0-werror.patch')
-rw-r--r--package/libroxml/libroxml-2.2.0-werror.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/package/libroxml/libroxml-2.2.0-werror.patch b/package/libroxml/libroxml-2.2.0-werror.patch
new file mode 100644
index 000000000..a72f2a786
--- /dev/null
+++ b/package/libroxml/libroxml-2.2.0-werror.patch
@@ -0,0 +1,22 @@
+[PATCH] remove -Werror from CFLAGS
+
+-Werror should only be used during development, not in released SW.
+
+Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
+---
+ Makefile | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+Index: libroxml-2.1.0/Makefile
+===================================================================
+--- libroxml-2.1.0.orig/Makefile
++++ libroxml-2.1.0/Makefile
+@@ -41,7 +41,7 @@
+
+ # options
+ override CPPFLAGS += -Iinc/
+-override CFLAGS += $(OPTIM) -fPIC -Wall -Wextra -Wno-unused -Werror -Iinc/ $(DEFINES)
++override CFLAGS += $(OPTIM) -fPIC -Wall -Wextra -Wno-unused -Iinc/ $(DEFINES)
+ override LDFLAGS +=
+
+ ifeq ("$(OS)", "Darwin")