summaryrefslogtreecommitdiffstats
path: root/package/lttng-libust/lttng-libust-dont-build-cxx-tests-when-not-available.patch
diff options
context:
space:
mode:
Diffstat (limited to 'package/lttng-libust/lttng-libust-dont-build-cxx-tests-when-not-available.patch')
-rw-r--r--package/lttng-libust/lttng-libust-dont-build-cxx-tests-when-not-available.patch45
1 files changed, 28 insertions, 17 deletions
diff --git a/package/lttng-libust/lttng-libust-dont-build-cxx-tests-when-not-available.patch b/package/lttng-libust/lttng-libust-dont-build-cxx-tests-when-not-available.patch
index d7be22d2f..bcc5636b5 100644
--- a/package/lttng-libust/lttng-libust-dont-build-cxx-tests-when-not-available.patch
+++ b/package/lttng-libust/lttng-libust-dont-build-cxx-tests-when-not-available.patch
@@ -1,19 +1,27 @@
-Do not build C++ example if a C++ compiler isn't available
+From 01dfa6e944d083db994f0a1165d3124bb6875437 Mon Sep 17 00:00:00 2001
+From: Samuel Martin <s.martin49@gmail.com>
+Date: Tue, 8 May 2012 15:13:21 +0200
+Subject: [PATCH 1/1] don't build C++ example if a C++ compiler isn't
+ available
By default lttng-ust builds a hello.cxx C++ example that demonstrates
-the usage of the userspace tracing library in a C++
-program. Unfortunately, when no C++ support is available, the build
-of lttng-ust fails just because of this example code. So we make the
-compilation of this code conditional on whether a working C++ compiler
-was found.
+the usage of the userspace tracing library in a C++ program.
+Unfortunately, when no C++ support is available, the build of lttng-ust
+fails just because of this example code. So we make the compilation of
+this code conditional on whether a working C++ compiler was found.
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
+Signed-off-by: Samuel Martin <s.martin49@gmail.com>
+---
+ configure.ac | 12 ++++++++++++
+ tests/Makefile.am | 6 +++++-
+ 2 files changed, 17 insertions(+), 1 deletion(-)
-Index: lttng-ust-1.9.2/configure.ac
-===================================================================
---- lttng-ust-1.9.2.orig/configure.ac 2012-02-04 14:49:45.387325814 +0100
-+++ lttng-ust-1.9.2/configure.ac 2012-02-04 14:50:08.156920117 +0100
-@@ -38,6 +38,18 @@
+diff --git a/configure.ac b/configure.ac
+index 26227cb..56d84db 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -45,6 +45,18 @@ AC_PROG_CXX
AC_PROG_MAKE_SET
LT_INIT
@@ -32,13 +40,13 @@ Index: lttng-ust-1.9.2/configure.ac
## Checks for libraries.
AC_CHECK_LIB([dl], [dlopen])
AC_CHECK_LIB([pthread], [pthread_create])
-Index: lttng-ust-1.9.2/tests/Makefile.am
-===================================================================
---- lttng-ust-1.9.2.orig/tests/Makefile.am 2012-02-04 14:49:49.157258640 +0100
-+++ lttng-ust-1.9.2/tests/Makefile.am 2012-02-04 14:50:15.096796474 +0100
+diff --git a/tests/Makefile.am b/tests/Makefile.am
+index e79ab7c..1a8b795 100644
+--- a/tests/Makefile.am
++++ b/tests/Makefile.am
@@ -1,6 +1,10 @@
--SUBDIRS = . hello fork ust-basic-tracing ust-multi-test demo hello.cxx
-+SUBDIRS = . hello fork ust-basic-tracing ust-multi-test demo
+-SUBDIRS = . hello hello-static-lib fork ust-basic-tracing ust-multi-test demo hello.cxx
++SUBDIRS = . hello hello-static-lib fork ust-basic-tracing ust-multi-test demo
#SUBDIRS = . hello2 basic basic_long simple_include snprintf test-nevents test-libustinstr-malloc dlopen same_line_marker trace_event register_test tracepoint libustctl_function_tests exit-fast
+if CXX_WORKS
@@ -48,3 +56,6 @@ Index: lttng-ust-1.9.2/tests/Makefile.am
dist_noinst_SCRIPTS = test_loop runtests trace_matches
noinst_LIBRARIES = libtap.a
+--
+1.7.10.1
+