summaryrefslogtreecommitdiffstats
path: root/package/monit/monit.mk
diff options
context:
space:
mode:
Diffstat (limited to 'package/monit/monit.mk')
-rw-r--r--package/monit/monit.mk30
1 files changed, 30 insertions, 0 deletions
diff --git a/package/monit/monit.mk b/package/monit/monit.mk
new file mode 100644
index 000000000..958618dc3
--- /dev/null
+++ b/package/monit/monit.mk
@@ -0,0 +1,30 @@
+#############################################################
+#
+# monit
+#
+#############################################################
+
+MONIT_VERSION = 5.4
+MONIT_SITE = http://mmonit.com/monit/dist/
+
+MONIT_CONF_ENV = \
+ libmonit_cv_setjmp_available=yes \
+ libmonit_cv_vsnprintf_c99_conformant=yes
+
+MONIT_CONF_OPT += \
+ --without-pam
+
+ifeq ($(BR2_PACKAGE_OPENSSL),y)
+MONIT_CONF_OPT += --with-ssl
+MONIT_DEPENDENCIES += openssl
+else
+MONIT_CONF_OPT += --without-ssl
+endif
+
+ifeq ($(BR2_LARGEFILE),y)
+MONIT_CONF_OPT += --with-largefiles
+else
+MONIT_CONF_OPT += --without-largefiles
+endif
+
+$(eval $(call AUTOTARGETS))