summaryrefslogtreecommitdiffstats
path: root/package/pciutils/pciutils.mk
diff options
context:
space:
mode:
Diffstat (limited to 'package/pciutils/pciutils.mk')
-rw-r--r--package/pciutils/pciutils.mk8
1 files changed, 8 insertions, 0 deletions
diff --git a/package/pciutils/pciutils.mk b/package/pciutils/pciutils.mk
index 37a17c475..7de5fd7b4 100644
--- a/package/pciutils/pciutils.mk
+++ b/package/pciutils/pciutils.mk
@@ -6,6 +6,7 @@
PCIUTILS_VERSION = 3.1.9
PCIUTILS_SITE = ftp://atrey.karlin.mff.cuni.cz/pub/linux/pci
+PCIUTILS_INSTALL_STAGING = YES
ifeq ($(BR2_PACKAGE_ZLIB),y)
PCIUTILS_ZLIB=yes
PCIUTILS_DEPENDENCIES += zlib
@@ -50,4 +51,11 @@ define PCIUTILS_INSTALL_TARGET_CMDS
SHARED=$(PCIUTILS_SHARED) install-lib
endef
+define PCIUTILS_INSTALL_STAGING_CMDS
+ $(MAKE) BUILDDIR=$(@D) -C $(@D) PREFIX=$(STAGING_DIR)/usr \
+ SHARED=$(PCIUTILS_SHARED) install
+ $(MAKE) BUILDDIR=$(@D) -C $(@D) PREFIX=$(STAGING_DIR)/usr \
+ SHARED=$(PCIUTILS_SHARED) install-lib
+endef
+
$(eval $(call GENTARGETS))