summaryrefslogtreecommitdiffstats
path: root/package/qt/qt.mk
diff options
context:
space:
mode:
Diffstat (limited to 'package/qt/qt.mk')
-rw-r--r--package/qt/qt.mk10
1 files changed, 7 insertions, 3 deletions
diff --git a/package/qt/qt.mk b/package/qt/qt.mk
index eb1ef0ffe..92f1253c7 100644
--- a/package/qt/qt.mk
+++ b/package/qt/qt.mk
@@ -12,7 +12,7 @@
#
######################################################################
-QT_VERSION:=4.6.2
+QT_VERSION:=4.6.3
QT_SOURCE:=qt-everywhere-opensource-src-$(QT_VERSION).tar.gz
QT_SITE:=http://get.qt.nokia.com/qt/source
QT_CAT:=$(ZCAT)
@@ -48,6 +48,12 @@ else
QT_CONFIGURE+= -no-qt3support
endif
+ifeq ($(BR2_PACKAGE_QT_DEMOS),y)
+QT_CONFIGURE+= -examplesdir $(TARGET_DIR)/usr/share/qt/examples -demosdir $(TARGET_DIR)/usr/share/qt/demos
+else
+QT_CONFIGURE+= -nomake examples -nomake demos
+endif
+
# ensure glib is built first if enabled for Qt's glib support
ifeq ($(BR2_PACKAGE_LIBGLIB2),y)
QT_DEP_LIBS+=libglib2
@@ -520,8 +526,6 @@ endif
-hostprefix $(STAGING_DIR)/usr \
-fast \
-no-rpath \
- -nomake examples \
- -nomake demos \
)
touch $@