summaryrefslogtreecommitdiffstats
path: root/package/tremor
diff options
context:
space:
mode:
Diffstat (limited to 'package/tremor')
-rw-r--r--package/tremor/Config.in7
-rw-r--r--package/tremor/tremor.mk15
2 files changed, 22 insertions, 0 deletions
diff --git a/package/tremor/Config.in b/package/tremor/Config.in
new file mode 100644
index 000000000..2e58e0985
--- /dev/null
+++ b/package/tremor/Config.in
@@ -0,0 +1,7 @@
+config BR2_PACKAGE_TREMOR
+ bool "tremor (fixed point vorbis decoder)"
+ help
+ Tremor is a fixed point implementation of an Ogg Vorbis
+ decoder. It provides a decoding API similar to libvorbis,
+ but gives much better performance on systems without a
+ floating-point unit.
diff --git a/package/tremor/tremor.mk b/package/tremor/tremor.mk
new file mode 100644
index 000000000..b83601098
--- /dev/null
+++ b/package/tremor/tremor.mk
@@ -0,0 +1,15 @@
+############################################################
+#
+# Tremor (Integer decoder for Vorbis)
+#
+############################################################
+
+TREMOR_SITE = http://svn.xiph.org/trunk/Tremor/
+TREMOR_SITE_METHOD = svn
+TREMOR_VERSION = 18153
+
+TREMOR_AUTORECONF = YES
+TREMOR_INSTALL_STAGING = YES
+TREMOR_DEPENDENCIES = libogg
+
+$(eval $(call AUTOTARGETS))