summaryrefslogtreecommitdiffstats
path: root/package/xorg/xorg.mk
diff options
context:
space:
mode:
Diffstat (limited to 'package/xorg/xorg.mk')
-rw-r--r--package/xorg/xorg.mk24
1 files changed, 16 insertions, 8 deletions
diff --git a/package/xorg/xorg.mk b/package/xorg/xorg.mk
index 15a590796..34a39e262 100644
--- a/package/xorg/xorg.mk
+++ b/package/xorg/xorg.mk
@@ -51,21 +51,29 @@ endif
# figure out Xorg's idea of corresponding architecture name
ifeq ($(BR2_alpha),y)
XARCH=Alpha
-else ifeq ($(BR2_arm),y)
+endif
+ifeq ($(BR2_arm),y)
XARCH=Arm32
-else ifeq ($(BR2_armeb),y)
+endif
+ifeq ($(BR2_armeb),y)
XARCH=Arm32
-else ifeq ($(BR2_i386),y)
+endif
+ifeq ($(BR2_i386),y)
XARCH=i386A
-else ifeq ($(BR2_mips),y)
+endif
+ifeq ($(BR2_mips),y)
XARCH=Mips
-else ifeq ($(BR2_mipsel),y)
+endif
+ifeq ($(BR2_mipsel),y)
XARCH=Mips
-else ifeq ($(BR2_powerpc),y)
+endif
+ifeq ($(BR2_powerpc),y)
XARCH=Ppc
-else ifeq ($(BR2_sparc),y)
+endif
+ifeq ($(BR2_sparc),y)
XARCH=Sparc
-else ifeq ($(BR2_x86_64),y)
+endif
+ifeq ($(BR2_x86_64),y)
XARCH=AMD64
endif