summaryrefslogtreecommitdiffstats
path: root/target/device/Atmel/Makefile.in
diff options
context:
space:
mode:
Diffstat (limited to 'target/device/Atmel/Makefile.in')
-rw-r--r--target/device/Atmel/Makefile.in54
1 files changed, 24 insertions, 30 deletions
diff --git a/target/device/Atmel/Makefile.in b/target/device/Atmel/Makefile.in
index a649f97c2..570941182 100644
--- a/target/device/Atmel/Makefile.in
+++ b/target/device/Atmel/Makefile.in
@@ -3,34 +3,34 @@
ifeq ($(strip $(BR2_TARGET_ATMEL)),y)
ATMEL_PATH:=target/device/Atmel
-BOARD_NAME:=$(strip $(subst ",, $(BR2_BOARD_NAME)))
+BOARD_NAME:=$(strip $(subst ",, $(BR2_BOARD_NAME)))
#"))
-BOARD_PATH:=$(strip $(subst ",, $(BR2_BOARD_PATH)))
+BOARD_PATH:=$(strip $(subst ",, $(BR2_BOARD_PATH)))
#"))
ATMEL_TARGET:=$(ATMEL_PATH)/root
-TARGET_SKELETON:=$(ATMEL_TARGET)/target_skeleton
+TARGET_SKELETON:=$(BOARD_PATH)/target_skeleton
TARGET_DEVICE_TABLE:=$(ATMEL_TARGET)/device_table.txt
TARGET_SKELETON_LINKS:=$(ATMEL_TARGET)/skel.tar.gz
-TARGET_ATMEL_COPYTO:=$(strip $(subst ",, $(BR2_TARGET_ATMEL_COPYTO)))
+TARGET_ATMEL_COPYTO:=$(strip $(subst ",, $(BR2_TARGET_ATMEL_COPYTO)))
# These are set by Config.in
-DOWNLOAD_LINUX26_VERSION:=$(strip $(subst ",, $(BR2_DOWNLOAD_LINUX26_VERSION)))
+DOWNLOAD_LINUX26_VERSION:=$(strip $(subst ",, $(BR2_DOWNLOAD_LINUX26_VERSION)))
#"))
ifeq ($(DOWNLOAD_LINUX26_VERSION),)
DOWNLOAD_LINUX26_VERSION=$(LINUX_HEADERS_VERSION)
endif
-LINUX26_VERSION:=$(strip $(subst ",, $(BR2_LINUX26_VERSION)))
+LINUX26_VERSION:=$(strip $(subst ",, $(BR2_LINUX26_VERSION)))
#"))
ifeq ($(LINUX26_VERSION),)
LINUX26_VERSION=$(LINUX_HEADERS_VERSION)
endif
-LINUX26_RC_PATCH:=$(strip $(subst ",, $(BR2_LINUX26_RC_PATCH)))
+LINUX26_RC_PATCH:=$(strip $(subst ",, $(BR2_LINUX26_RC_PATCH)))
#"))
-LINUX_BSP_PATCH:=$(strip $(subst ",, $(BR2_LINUX_BSP_ATMEL_PATCH)))
+LINUX_BSP_PATCH:=$(strip $(subst ",, $(BR2_LINUX_BSP_ATMEL_PATCH)))
#"))
# These are set by "new" Config.in
@@ -39,31 +39,15 @@ LINUX26_KCONFIG:=$(BOARD_PATH)/$(BOARD_NAME)-linux-$(LINUX26_VERSION).config
# This should be part of target/linux/Makefile.in
LINUX26_BUILD_DIR:=$(PROJECT_BUILD_DIR)
-#LINUX26_BINLOC=$(LINUX26_FORMAT)
+LINUX26_BINLOC=$(LINUX26_FORMAT)
#LINUX26_BINLOC:=$(BINARIES_DIR)/$(LINUX26_KERNEL)
-ifeq ($(BR2_avr32),y)
-AVR32_FORMAT:=$(strip $(subst ",,$(BR2_PACKAGE_LINUX_FORMAT)))
-#"))
-ifeq ($(AVR32_FORMAT),uImage)
-LINUX26_BINLOC=arch/$(KERNEL_ARCH)/boot/images/$(AVR32_FORMAT)
-endif
+ifeq ($(strip $(BR2_avr32)),y)
+LINUX26_BINLOC:=arch/$(KERNEL_ARCH)/boot/images/$(BR2_PACKAGE_LINUX_FORMAT)
endif
-
LINUX26_COPYTO:=/tftpboot
-ifeq ($(DEFAULT_KERNEL_HEADERS),2.6.22.1)
-KERNEL_HEADERS_PATCH_DIR:=target/device/Atmel/linux/kernel-patches-$(LINUX26_VERSION)
-else
-# Patch during kernel header build
-ifeq ($(BR2_avr32),y)
-KERNEL_HEADERS_PATCH_DIR:=target/device/Atmel/arch-avr32/kernel-patches-$(LINUX26_VERSION)
-endif
-# Patch during kernel build
-ifeq ($(BR2_arm),y)
-KERNEL_HEADERS_PATCH_DIR:=target/device/Atmel/arch-arm/kernel-patches-$(LINUX26_VERSION)
-endif
-endif
+LINUX26_PATCH_DIR:=$(BOARD_PATH)/kernel-patches
# The board specific Makefile.in can redefine BOARD_NAME's
LINUX_BOARD_NAME:=$(BOARD_NAME)
@@ -72,7 +56,6 @@ DFB_BOARD_NAME:=$(BOARD_NAME)
BR2_PACKAGE_BUSYBOX_CONFIG:=$(BR2_BOARD_PATH)/busybox-$(BR2_BUSYBOX_VERSION).config
-#LINUX26_KERNEL=$(BINARIES_DIR)/$(PROJECT)-linux-$(LINUX26_VERSION)-$(DATE)
# Update things in board specific makefiles
include target/device/Atmel/*/Makefile.in
@@ -83,7 +66,7 @@ UBOOT_CONFIG:=$(UBOOT_BOARD_NAME)_config
UBOOT_CONFIG_FILE:=$(BOARD_PATH)/u-boot/$(UBOOT_BOARD_NAME).h
ifeq ($(strip $(BR2_PACKAGE_LINUX)),y)
-include $(ATMEL_PATH)/linux/linux.mk
+#include $(ATMEL_PATH)/Linux/linux.mk
endif
ifeq ($(strip $(BR2_TARGET_UBOOT)),y)
@@ -98,4 +81,15 @@ ifeq ($(strip $(BR2_TARGET_AT91BOOTSTRAP)),y)
include $(ATMEL_PATH)/at91bootstrap/at91bootstrap.mk
endif
+atmel_status:
+ @echo PROJECT_BUILD_DIR=$(PROJECT_BUILD_DIR)
+ @echo BOARD_NAME=$(BOARD_NAME)
+ @echo BR2_BOARD_PATH=$(BR2_BOARD_PATH)
+ @echo BR2_MAJOR_MINOR=$(BR2_LINUX_MAJOR_VERSION)$(BR2_LINUX_MINOR_VERSION)
+ @echo MAJOR_MINOR=$(LINUX_MAJOR_VER)$(LINUX_MINOR_VER)
+ @echo DOWNLOAD_LINUX26_VERSION=$(DOWNLOAD_LINUX26_VERSION)
+ @echo LINUX_SOURCE=$(LINUX_SOURCE)
+ @echo TARGETS=$(TARGETS)
+
+#TARGETS+=atmel_status
endif