summaryrefslogtreecommitdiffstats
path: root/target/linux/Makefile.in
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/Makefile.in')
-rw-r--r--target/linux/Makefile.in6
1 files changed, 3 insertions, 3 deletions
diff --git a/target/linux/Makefile.in b/target/linux/Makefile.in
index 18c98b4c2..619b5706b 100644
--- a/target/linux/Makefile.in
+++ b/target/linux/Makefile.in
@@ -58,7 +58,7 @@ endif
LINUX26_KERNEL=linux-kernel-$(LINUX26_VERSION)-$(KERNEL_ARCH)
# Version of Linux AFTER patches
-LINUX26_DIR=$(BUILD_DIR)/linux-$(LINUX26_VERSION)
+LINUX26_DIR=$(PROJECT_BUILD_DIR)/linux-$(LINUX26_VERSION)
# for packages that need it
LINUX_VERSION:=$(LINUX_VERSION)
@@ -89,10 +89,10 @@ $(DL_DIR)/$(LINUX26_SOURCE):
$(LINUX26_DIR)/.unpacked: $(DL_DIR)/$(LINUX26_SOURCE)
rm -rf $(LINUX26_DIR)
- $(LINUX26_BZCAT) $(DL_DIR)/$(LINUX26_SOURCE) | tar -C $(BUILD_DIR) $(TAR_OPTIONS) -
+ $(LINUX26_BZCAT) $(DL_DIR)/$(LINUX26_SOURCE) | tar -C $(PROJECT_BUILD_DIR) $(TAR_OPTIONS) -
ifneq ($(DOWNLOAD_LINUX26_VERSION),$(LINUX26_VERSION))
# Rename the dir from the downloaded version to the AFTER patch version
- mv -f $(BUILD_DIR)/linux-$(DOWNLOAD_LINUX26_VERSION) $(LINUX26_DIR)
+ mv -f $(PROJECT_BUILD_DIR)/linux-$(DOWNLOAD_LINUX26_VERSION) $(LINUX26_DIR)
endif
touch $@