summaryrefslogtreecommitdiffstats
path: root/target/powerpc/yaboot/yaboot.mk
diff options
context:
space:
mode:
Diffstat (limited to 'target/powerpc/yaboot/yaboot.mk')
-rw-r--r--target/powerpc/yaboot/yaboot.mk44
1 files changed, 0 insertions, 44 deletions
diff --git a/target/powerpc/yaboot/yaboot.mk b/target/powerpc/yaboot/yaboot.mk
deleted file mode 100644
index cbeae5086..000000000
--- a/target/powerpc/yaboot/yaboot.mk
+++ /dev/null
@@ -1,44 +0,0 @@
-ifeq ($(ARCH),powerpc)
-
-#############################################################
-#
-# yaboot
-#
-#############################################################
-
-YABOOT_SOURCE:=yaboot-1.3.13.tar.gz
-YABOOT_SITE:=http://penguinppc.org/bootloaders/yaboot
-YABOOT_DIR:=$(BUILD_DIR)/yaboot-1.3.13
-
-$(DL_DIR)/$(YABOOT_SOURCE):
- $(call DOWNLOAD,$(YABOOT_SITE),$(YABOOT_SOURCE))
-
-yaboot-source: $(DL_DIR)/$(YABOOT_SOURCE)
-
-$(YABOOT_DIR)/Makefile: $(DL_DIR)/$(YABOOT_SOURCE)
- $(ZCAT) $(DL_DIR)/$(YABOOT_SOURCE) | tar -C $(BUILD_DIR) -xvf -
- touch -c $(YABOOT_DIR)/Makefile
-
-$(YABOOT_DIR)/second/yaboot: $(YABOOT_DIR)/Makefile
- $(MAKE) -C $(YABOOT_DIR) CROSS=$(TARGET_CROSS)
- touch -c $(YABOOT_DIR)/second/yaboot
-
-yaboot: $(YABOOT_DIR)/second/yaboot
-
-yaboot-clean:
- $(MAKE) -C $(YABOOT_DIR) clean
-
-yaboot-dirclean:
- rm -rf $(YABOOT_DIR)
-
-endif
-
-#############################################################
-#
-# Toplevel Makefile options
-#
-#############################################################
-ifeq ($(BR2_TARGET_YABOOT),y)
-TARGETS+=yaboot
-endif
-