summaryrefslogtreecommitdiffstats
path: root/toolchain/Makefile.in
diff options
context:
space:
mode:
Diffstat (limited to 'toolchain/Makefile.in')
-rw-r--r--toolchain/Makefile.in6
1 files changed, 6 insertions, 0 deletions
diff --git a/toolchain/Makefile.in b/toolchain/Makefile.in
index ca798bf6b..6f7cc013d 100644
--- a/toolchain/Makefile.in
+++ b/toolchain/Makefile.in
@@ -10,6 +10,12 @@ else
MULTILIB:=--disable-multilib
endif
+ifeq ($(BR2_PREFER_STATIC_LIB),y)
+PREFERRED_LIB_FLAGS:=--enable-static --disable-shared
+else
+PREFERRED_LIB_FLAGS:=--disable-static --enable-shared
+endif
+
# FIXME -- this is temporary
OPTIMIZE_FOR_CPU=$(ARCH)