summaryrefslogtreecommitdiffstats
path: root/doc/CMakeLists.txt
diff options
context:
space:
mode:
authorSebastian Schmelzer2011-12-15 17:32:06 +0100
committerSebastian Schmelzer2011-12-15 17:32:06 +0100
commit21163c0288714e0ebb42d917f9ca9b8aa17bb26b (patch)
tree92dbb66c5e4aa34980c323580d25e6bc54ac3fe2 /doc/CMakeLists.txt
parentspelling .. (diff)
downloadfbgui-21163c0288714e0ebb42d917f9ca9b8aa17bb26b.tar.gz
fbgui-21163c0288714e0ebb42d917f9ca9b8aa17bb26b.tar.xz
fbgui-21163c0288714e0ebb42d917f9ca9b8aa17bb26b.zip
add doc build target
Diffstat (limited to 'doc/CMakeLists.txt')
-rw-r--r--doc/CMakeLists.txt11
1 files changed, 11 insertions, 0 deletions
diff --git a/doc/CMakeLists.txt b/doc/CMakeLists.txt
new file mode 100644
index 0000000..bc5c43f
--- /dev/null
+++ b/doc/CMakeLists.txt
@@ -0,0 +1,11 @@
+# add a target to generate API documentation with Doxygen
+find_package(Doxygen)
+if(DOXYGEN_FOUND)
+ configure_file(${CMAKE_CURRENT_SOURCE_DIR}/Doxyfile.in.dox ${CMAKE_CURRENT_BINARY_DIR}/Doxyfile.dox @ONLY)
+ add_custom_target(doc
+ ${DOXYGEN_EXECUTABLE} ${CMAKE_CURRENT_BINARY_DIR}/Doxyfile.dox
+ WORKING_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}
+ COMMENT "Generating API documentation with Doxygen" VERBATIM
+ )
+endif(DOXYGEN_FOUND)
+