summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt28
1 files changed, 28 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 0000000..6ee8d65
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,28 @@
+cmake_minimum_required(VERSION 2.8)
+
+project(fbsplash)
+
+find_package(Qt4 REQUIRED)
+if (QT4_FOUND)
+ message(STATUS "QT4 found.")
+else(QT4_FOUND)
+ message(FATAL_ERROR "QT4 not found!")
+endif(QT4_FOUND)
+
+file(GLOB_RECURSE fbsplash_SOURCES src/*.cpp)
+file(GLOB_RECURSE fbsplash_MOC_HEADERS src/*.h)
+
+#set(fbsplash_SOURCES main.cpp fbsplash.cpp)
+#set(fbsplash_HEADERS fbsplash.h)
+
+QT4_WRAP_CPP(fbsplash_MOC_SOURCES ${fbsplash_MOC_HEADERS})
+
+include(${QT_USE_FILE})
+add_definitions(${QT_DEFINITIONS})
+
+add_executable(fbsplash ${fbsplash_SOURCES}
+ ${fbsplash_MOC_SOURCES})
+
+target_link_libraries(fbsplash ${QT_LIBRARIES})
+
+include_directories(${CMAKE_CURRENT_BINARY_DIR})