summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt15
1 files changed, 8 insertions, 7 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 6ee8d65..8cf1160 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -11,17 +11,18 @@ endif(QT4_FOUND)
file(GLOB_RECURSE fbsplash_SOURCES src/*.cpp)
file(GLOB_RECURSE fbsplash_MOC_HEADERS src/*.h)
+file(GLOB_RECURSE fbsplash_UIS src/*.ui)
-#set(fbsplash_SOURCES main.cpp fbsplash.cpp)
-#set(fbsplash_HEADERS fbsplash.h)
-
-QT4_WRAP_CPP(fbsplash_MOC_SOURCES ${fbsplash_MOC_HEADERS})
-
include(${QT_USE_FILE})
add_definitions(${QT_DEFINITIONS})
-add_executable(fbsplash ${fbsplash_SOURCES}
- ${fbsplash_MOC_SOURCES})
+QT4_WRAP_UI(fbsplash_UI_HEADERS ${fbsplash_UIS})
+QT4_WRAP_CPP(fbsplash_MOC_SOURCES ${fbsplash_MOC_HEADERS})
+
+add_executable(fbsplash
+ ${fbsplash_SOURCES}
+ ${fbsplash_MOC_SOURCES}
+ ${fbsplash_UI_HEADERS})
target_link_libraries(fbsplash ${QT_LIBRARIES})