summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorLuís Pereira2016-10-07 15:38:12 +0200
committerLuís Pereira2016-10-07 15:38:12 +0200
commit8e61ef5c4c8cd3b561785683044739d6c40fd9ef (patch)
treec60c5d22766d79c62ac8488d98fe76d82888bee2 /CMakeLists.txt
parentMerge pull request #17 from heliocastro/singleapp (diff)
downloadpavucontrol-slx-8e61ef5c4c8cd3b561785683044739d6c40fd9ef.tar.gz
pavucontrol-slx-8e61ef5c4c8cd3b561785683044739d6c40fd9ef.tar.xz
pavucontrol-slx-8e61ef5c4c8cd3b561785683044739d6c40fd9ef.zip
Use the new lxqt-build-tools package
Drop liblxqt build time dependency. Add Qt5DBus to the required packaged.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 4bdab32..de74c83 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -3,6 +3,7 @@ project(pavucontrol-qt)
option(UPDATE_TRANSLATIONS "Update source translation translations/*.ts files" OFF)
+set(LXQTBT_MINIMUM_VERSION "0.1.0")
list(APPEND CMAKE_MODULE_PATH "${CMAKE_CURRENT_SOURCE_DIR}/cmake")
set(CMAKE_INCLUDE_CURRENT_DIR ON)
@@ -14,8 +15,9 @@ include(GNUInstallDirs)
find_package(Qt5Widgets REQUIRED QUIET)
find_package(Qt5LinguistTools REQUIRED QUIET)
+find_package(Qt5DBus REQUIRED)
-find_package(lxqt REQUIRED QUIET)
+find_package(lxqt-build-tools ${LXQTBT_MINIMUM_VERSION} REQUIRED)
include(LXQtCompilerSettings NO_POLICY_SCOPE)
include(LXQtTranslate)