summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorLuís Pereira2018-05-02 17:44:39 +0200
committerAlf Gaida2018-05-06 13:17:37 +0200
commit9ce03fb98900e7aded298a3df43a27a9445dc915 (patch)
treeec1c3869b91523f462a15a09161342f5af0ace7f /CMakeLists.txt
parentbuild: Use pkg-config's *_LDFLAGS (diff)
downloadpavucontrol-slx-9ce03fb98900e7aded298a3df43a27a9445dc915.tar.gz
pavucontrol-slx-9ce03fb98900e7aded298a3df43a27a9445dc915.tar.xz
pavucontrol-slx-9ce03fb98900e7aded298a3df43a27a9445dc915.zip
CMake: Prevent in-source builds
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 7adf7ac..edf7e54 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -3,7 +3,7 @@ project(pavucontrol-qt)
option(UPDATE_TRANSLATIONS "Update source translation translations/*.ts files" OFF)
-set(LXQTBT_MINIMUM_VERSION "0.4.0")
+set(LXQTBT_MINIMUM_VERSION "0.5.0")
list(APPEND CMAKE_MODULE_PATH "${CMAKE_CURRENT_SOURCE_DIR}/cmake")
set(CMAKE_INCLUDE_CURRENT_DIR ON)
@@ -29,6 +29,7 @@ set(PAVUCONTROLQT_PATCH_VERSION 0)
set(PAVUCONTROLQT_VERSION ${PAVUCONTROLQT_MAJOR_VERSION}.${PAVUCONTROLQT_MINOR_VERSION}.${PAVUCONTROLQT_PATCH_VERSION})
add_definitions("-DPAVUCONTROLQT_VERSION=\"${PAVUCONTROLQT_VERSION}\"")
+include(LXQtPreventInSourceBuilds)
include(LXQtCompilerSettings NO_POLICY_SCOPE)
include(LXQtTranslate)