summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorTsu Jan2020-08-16 20:56:13 +0200
committerTsu Jan2020-08-16 20:56:13 +0200
commit0ae1420bbc7639033cbb7417697f6a75924ddf02 (patch)
tree5ff6fe76da3c68aad10c3b91a70f604c47e2bfaf /src/CMakeLists.txt
parentMerge pull request #160 from zoli111/master (diff)
downloadpavucontrol-slx-0ae1420bbc7639033cbb7417697f6a75924ddf02.tar.gz
pavucontrol-slx-0ae1420bbc7639033cbb7417697f6a75924ddf02.tar.xz
pavucontrol-slx-0ae1420bbc7639033cbb7417697f6a75924ddf02.zip
GUI fixes: Elide playback name label if needed and…
If the name is too long, elide it centrally, so that a horizontal scrollbar isn't needed (and isn't shown). Also, don't force a height on progressbars because some widget styles may not show any bar with a forced height. Closes https://github.com/lxqt/pavucontrol-qt/issues/99 and closes https://github.com/lxqt/pavucontrol-qt/issues/75
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 89b0272..c686632 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -16,6 +16,7 @@ set(pavucontrol-qt_HDRS
sourceoutputwidget.h
sourcewidget.h
streamwidget.h
+ elidinglabel.h
)
set(pavucontrol-qt_SRCS
@@ -31,6 +32,7 @@ set(pavucontrol-qt_SRCS
sourceoutputwidget.cc
sourcewidget.cc
streamwidget.cc
+ elidinglabel.cc
)
set(pavucontrol-qt_UI