summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorChristian Klinger2016-06-01 14:47:40 +0200
committerChristian Klinger2016-06-01 14:47:40 +0200
commitc04f102458227e41e8ef13064f5ace371a0cd9ba (patch)
tree4528fcc6dddb72cdd8c389e300f0dd572356dd66 /CMakeLists.txt
parent[printergui] Interpret --error message as utf8 (diff)
downloadprintergui-c04f102458227e41e8ef13064f5ace371a0cd9ba.tar.gz
printergui-c04f102458227e41e8ef13064f5ace371a0cd9ba.tar.xz
printergui-c04f102458227e41e8ef13064f5ace371a0cd9ba.zip
added x11 workaround.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 4d9b9cb..7dfe756 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -20,6 +20,7 @@ SET(CMAKE_MODULE_PATH ${CMAKE_SOURCE_DIR}/cmake)
# this command finds libraries and sets all required variables
FIND_PACKAGE(Qt4 REQUIRED)
FIND_PACKAGE(Cups REQUIRED)
+FIND_PACKAGE(X11 REQUIRED)
# some includes
INCLUDE_DIRECTORIES(
@@ -131,10 +132,12 @@ ADD_EXECUTABLE(printpwgui
TARGET_LINK_LIBRARIES(printergui
${QT_LIBRARIES}
${CUPS_LIBRARIES}
+ ${X11_LIBRARIES}
)
TARGET_LINK_LIBRARIES(printpwgui
${QT_LIBRARIES}
+ ${X11_LIBRARIES}
)
# install