summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt13
1 files changed, 8 insertions, 5 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 0745441..4d9b9cb 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -9,10 +9,10 @@ CMAKE_MINIMUM_REQUIRED(VERSION 2.8.0)
IF (CMAKE_BUILD_TYPE STREQUAL "")
SET(CMAKE_BUILD_TYPE Debug)
ENDIF()
-SET(CMAKE_C_FLAGS_DEBUG "-O0 -g -Wall -Wunused -Wunreachable-code -pedantic -fno-strict-aliasing")
-SET(CMAKE_C_FLAGS_RELEASE "-O2 -fno-strict-aliasing")
-SET(CMAKE_CXX_FLAGS_DEBUG "-O0 -g -Wall -Wunused -Wunreachable-code -pedantic -fno-strict-aliasing")
-SET(CMAKE_CXX_FLAGS_RELEASE "-O2 -fno-strict-aliasing" )
+SET(CMAKE_C_FLAGS_DEBUG "-O0 -g -Wall -Wunused -Wunreachable-code -pedantic -fno-strict-aliasing -std=gnu99")
+SET(CMAKE_C_FLAGS_RELEASE "-O2 -fno-strict-aliasing -std=gnu99")
+SET(CMAKE_CXX_FLAGS_DEBUG "-O0 -g -Wall -Wunused -Wunreachable-code -pedantic -fno-strict-aliasing -std=gnu++0x")
+SET(CMAKE_CXX_FLAGS_RELEASE "-O2 -fno-strict-aliasing -std=gnu++0x" )
# local cmake modules
SET(CMAKE_MODULE_PATH ${CMAKE_SOURCE_DIR}/cmake)
@@ -34,11 +34,13 @@ INCLUDE_DIRECTORIES(
# printergui (maingui)
FILE(GLOB MAINGUI_SRCS
src/maingui/*.cpp
+ src/*.cpp
)
# password gui (printpwgui
FILE(GLOB PWGUI_SRCS
src/pwgui/*.cpp
+ src/*.cpp
)
################################################################################
@@ -61,11 +63,12 @@ FILE(GLOB PWGUI_UIS
# includes all header files that should be treated with moc
SET(MAINGUI_MOC_HDRS
src/maingui/printergui.h
- src/maingui/backdrop.h
+ src/backdrop.h
)
SET(PWGUI_MOC_HDRS
src/pwgui/pwgui.h
+ src/backdrop.h
)
# i18n