summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 7 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2fd0179..55282d2 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -14,6 +14,7 @@ file(GLOB_RECURSE UIS src/*.ui)
find_package(Qt5Widgets REQUIRED)
find_package(Qt5Svg REQUIRED)
+FIND_PACKAGE(X11 REQUIRED)
QT5_ADD_RESOURCES(RSCS qt-lightdm-greeter.qrc)
@@ -29,7 +30,12 @@ include_directories ( ${CMAKE_CURRENT_SOURCE_DIR}
add_executable ( qt-lightdm-greeter ${SRCS} ${RSCS} ${UI_HEADERS} )
-target_link_libraries ( qt-lightdm-greeter Qt5::Widgets Qt5::Svg ${LIGHTDM_QT_LIBRARIES} )
+target_link_libraries ( qt-lightdm-greeter
+ Qt5::Widgets
+ Qt5::Svg
+ ${LIGHTDM_QT_LIBRARIES}
+ ${X11_LIBRARIES}
+)
install(TARGETS ${PROJECT} RUNTIME DESTINATION bin)