summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSimon Rettberg2022-06-20 16:25:54 +0200
committerSimon Rettberg2022-06-20 16:25:54 +0200
commit72a05e138ec579cd567939eb0b33b0ea476820fb (patch)
tree8d94b35d043430dcf952e50082496f90db9e3ad7 /CMakeLists.txt
parentFix use after free (diff)
downloadspeedcheck-72a05e138ec579cd567939eb0b33b0ea476820fb.tar.gz
speedcheck-72a05e138ec579cd567939eb0b33b0ea476820fb.tar.xz
speedcheck-72a05e138ec579cd567939eb0b33b0ea476820fb.zip
Fix deprecation warnings where possible, make remaining ones -Wno-error
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 599979c..90caaa3 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -11,7 +11,7 @@ set(CMAKE_CXX_FLAGS_RELEASE "-O2 -Wno-multichar")
set(CMAKE_CXX_STANDARD 11)
# Some cmake versions can't understand the CMAKE_CXX_STANDARD option above?
-SET( CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++11" )
+SET( CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++11 -Wno-error=deprecated-declarations" )
set(CMAKE_INCLUDE_CURRENT_DIR ON)
set(CMAKE_AUTOMOC ON)