summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorManuel Bentele2020-09-15 13:38:21 +0200
committerManuel Bentele2020-09-16 07:37:56 +0200
commit0498df6a42c4c1283baf1182823842db6cbb3018 (patch)
tree4282d7616b1e8c93a4a204c946e0f56a1509e7e7 /CMakeLists.txt
parentAdded partial CMake package component support (diff)
downloadxloop-0498df6a42c4c1283baf1182823842db6cbb3018.tar.gz
xloop-0498df6a42c4c1283baf1182823842db6cbb3018.tar.xz
xloop-0498df6a42c4c1283baf1182823842db6cbb3018.zip
Changed CMake minimum required version to 3.10
This change fixes build issues with the CMake version shipped with CentOS 8.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 560cb71..1b3d2a2 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -6,8 +6,7 @@ include(version)
# define root CMake project
project(xloop
- DESCRIPTION "xloop Kernel modules and utility"
- HOMEPAGE_URL "https://git.openslx.org/openslx-ng/xloop.git/"
+ DESCRIPTION "xloop Linux kernel modules and utility"
LANGUAGES C)
# define project specific settings
@@ -45,6 +44,7 @@ if(${CMAKE_BUILD_TYPE} MATCHES Release)
set(CPACK_PACKAGE_SECTION admin)
set(CPACK_PACKAGE_VENDOR "University of Freiburg")
set(CPACK_PACKAGE_CONTACT "Christian Rößler <christian.roessler@rz.uni-freiburg.de>")
+ set(CPACK_PACKAGE_HOMEPAGE_URL "https://git.openslx.org/openslx-ng/xloop.git/")
set(CPACK_PACKAGE_CHECKSUM SHA256)
set(CPACK_PACKAGE_FILE_NAME ${CPACK_PACKAGE_NAME}_${CPACK_PACKAGE_VERSION}_${CMAKE_SYSTEM_PROCESSOR})
set(CPACK_SOURCE_PACKAGE_FILE_NAME ${CPACK_PACKAGE_NAME}_${CPACK_PACKAGE_VERSION}_source)