summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorManuel Bentele2020-10-12 09:11:17 +0200
committerManuel Bentele2020-10-12 09:11:17 +0200
commitb2db527b9674174b704aaa297afa257215d8a290 (patch)
tree0ff37200d76c65178d220a61ededcb2344645b63 /CMakeLists.txt
parentUpdated README with required build tools and libraries (diff)
downloadxloop-b2db527b9674174b704aaa297afa257215d8a290.tar.gz
xloop-b2db527b9674174b704aaa297afa257215d8a290.tar.xz
xloop-b2db527b9674174b704aaa297afa257215d8a290.zip
Print version string in kernel log
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 3095d7e..fa32699 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -31,7 +31,8 @@ endif()
# get versions to define project version
get_kernel_version(LINUX_KERNEL_VERSION)
get_repository_version(REPOSITORY_VERSION)
-set(VERSION ${LINUX_KERNEL_VERSION}-${REPOSITORY_VERSION})
+set(VERSION ${LINUX_KERNEL_VERSION}-${REPOSITORY_VERSION}
+ CACHE STRING "Version of xloop package")
# define packaging if Release build is enabled
if(${CMAKE_BUILD_TYPE} MATCHES Release)