summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorManuel Bentele2020-09-10 10:58:51 +0200
committerManuel Bentele2020-09-16 07:37:56 +0200
commitde77f01a0985432617ee21ad41ec39fecf55fec8 (patch)
treeec29220b7e5bd167ef3da44c515aea49b566d79d /CMakeLists.txt
parentRenamed files from loop to xloop and generate package only in Release mode (diff)
downloadxloop-de77f01a0985432617ee21ad41ec39fecf55fec8.tar.gz
xloop-de77f01a0985432617ee21ad41ec39fecf55fec8.tar.xz
xloop-de77f01a0985432617ee21ad41ec39fecf55fec8.zip
Fixed major number of xloop device and device names in xlosetup
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt11
1 files changed, 11 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ba17bf4..76439db 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -3,6 +3,17 @@ cmake_minimum_required(VERSION 3.10)
# set the project name
project(xloop)
+# define project specific settings
+set(BLK_DEV_XLOOP_MIN_COUNT 8
+ CACHE STRING "Number of xloop devices to pre-create at init time")
+set(XLOOP_MAJOR 120
+ CACHE STRING "Major number for xloop devices")
+
+# print configured settings
+message(STATUS "Number of xloop devices to pre-create at init time is " ${BLK_DEV_XLOOP_MIN_COUNT})
+message(STATUS "Major number for xloop devices is " ${XLOOP_MAJOR})
+
+# set compilation in debug mode as default configuration
if(NOT CMAKE_BUILD_TYPE)
set(CMAKE_BUILD_TYPE "Debug")
endif()