summaryrefslogtreecommitdiffstats
path: root/kernel/CMakeLists.txt
diff options
context:
space:
mode:
authorManuel Bentele2020-10-07 14:34:25 +0200
committerManuel Bentele2020-10-07 14:34:25 +0200
commit23008cde712028bc7e7d56d9fd7cbe3da07d80fa (patch)
tree71bfe3acea3a81d8bd8621d2d051240123d997e2 /kernel/CMakeLists.txt
parentUpdated QCOW file format driver with upstream patches (diff)
downloadxloop-23008cde712028bc7e7d56d9fd7cbe3da07d80fa.tar.gz
xloop-23008cde712028bc7e7d56d9fd7cbe3da07d80fa.tar.xz
xloop-23008cde712028bc7e7d56d9fd7cbe3da07d80fa.zip
Added udev rules to kernel module build of xloop
The added rules allow udev to properly detect disks and partitions exposed by the xloop kernel module. A proper detection of disks and partitions is needed by some command line tools from the util-linux package.
Diffstat (limited to 'kernel/CMakeLists.txt')
-rw-r--r--kernel/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/kernel/CMakeLists.txt b/kernel/CMakeLists.txt
index 2dace3f..0e867f6 100644
--- a/kernel/CMakeLists.txt
+++ b/kernel/CMakeLists.txt
@@ -74,3 +74,9 @@ add_kernel_module(xloop_file_fmt_qcow "${KERNEL_DIR}"
if(${CMAKE_BUILD_TYPE} MATCHES Debug)
add_subdirectory(tests)
endif()
+
+# install udev rules for xloop devices exposed by the xloop kernel module
+install(PROGRAMS ${CMAKE_CURRENT_SOURCE_DIR}/udev/50-xloop.rules
+ DESTINATION /lib/udev/rules.d
+ PERMISSIONS OWNER_READ OWNER_WRITE GROUP_READ WORLD_READ
+ COMPONENT main)