summaryrefslogtreecommitdiffstats
path: root/kernel/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorManuel Bentele2020-10-13 16:19:21 +0200
committerManuel Bentele2020-10-13 16:19:21 +0200
commit111a2350ac1967b62ffa3024371819c812c46844 (patch)
treee31808a39291fe3bfa53e921a51dc74be36468ae /kernel/tests/CMakeLists.txt
parentAdded separate Linux kernel install directory and added version to kernel mod... (diff)
downloadxloop-111a2350ac1967b62ffa3024371819c812c46844.tar.gz
xloop-111a2350ac1967b62ffa3024371819c812c46844.tar.xz
xloop-111a2350ac1967b62ffa3024371819c812c46844.zip
Added support to keep track of kernel file changes in CMake
With this patch, CMake keeps track of changes to original xloop Linux kernel source files. CMake will copy each file if a change is detected without rebuiling the CMake build and cache files. Futhrmore, changed default paths of udev rules and xloop kernel modules to be installed.
Diffstat (limited to 'kernel/tests/CMakeLists.txt')
-rw-r--r--kernel/tests/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/kernel/tests/CMakeLists.txt b/kernel/tests/CMakeLists.txt
index f086864..e93ff9d 100644
--- a/kernel/tests/CMakeLists.txt
+++ b/kernel/tests/CMakeLists.txt
@@ -4,7 +4,7 @@ project(xloop-kernel-test)
include_directories(${CMAKE_CURRENT_SOURCE_DIR}/include)
include_directories(${CMAKE_CURRENT_SOURCE_DIR}/include/old)
-include_directories(${CMAKE_CURRENT_SOURCE_DIR}/../uapi)
+include_directories(${CMAKE_CURRENT_SOURCE_DIR}/..)
# configure configuration config.h and add it to the include directories
configure_file(${CMAKE_CURRENT_SOURCE_DIR}/include/config.h.in ${CMAKE_CURRENT_BINARY_DIR}/config.h)