summaryrefslogtreecommitdiffstats
path: root/src/kernel/CMakeLists.txt
diff options
context:
space:
mode:
authorManuel Bentele2020-10-27 07:23:38 +0100
committerManuel Bentele2020-10-27 07:23:38 +0100
commit089444e957d66375fbf4678a65d5106c7349223a (patch)
treeea58f8b1859579a004d53289281948d91dfc13be /src/kernel/CMakeLists.txt
parentAdd CMake build requirements check to find libraries and Linux kernel headers (diff)
downloadxloop-089444e957d66375fbf4678a65d5106c7349223a.tar.gz
xloop-089444e957d66375fbf4678a65d5106c7349223a.tar.xz
xloop-089444e957d66375fbf4678a65d5106c7349223a.zip
Remove the build requirement for an unused C++ compiler
This patch sets the programming languages of each CMake project to C. With this change, CMake does not search for an unused C++ compiler anymore.
Diffstat (limited to 'src/kernel/CMakeLists.txt')
-rw-r--r--src/kernel/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/src/kernel/CMakeLists.txt b/src/kernel/CMakeLists.txt
index 2f1446a..3dcc8a2 100644
--- a/src/kernel/CMakeLists.txt
+++ b/src/kernel/CMakeLists.txt
@@ -1,7 +1,8 @@
cmake_minimum_required(VERSION 3.10)
# set the project name
-project(xloop-kernel)
+project(xloop-kernel-modules
+ LANGUAGES C)
# include macros to define Linux kernel build targets
include(Kernel)