summaryrefslogtreecommitdiffstats
path: root/src/kernel/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorManuel Bentele2020-10-23 15:18:01 +0200
committerManuel Bentele2020-10-23 15:18:01 +0200
commitdbb41ce2b7f309d394054a6bd1e33afd578798a5 (patch)
tree6a31092063d9f2fb5ac5720ec6759040e793c3d5 /src/kernel/tests/CMakeLists.txt
parentSet Linux kernel version to unknown if it is not detectable (diff)
downloadxloop-dbb41ce2b7f309d394054a6bd1e33afd578798a5.tar.gz
xloop-dbb41ce2b7f309d394054a6bd1e33afd578798a5.tar.xz
xloop-dbb41ce2b7f309d394054a6bd1e33afd578798a5.zip
Move the source code of all xloop components to the common 'src' directory
Diffstat (limited to 'src/kernel/tests/CMakeLists.txt')
-rw-r--r--src/kernel/tests/CMakeLists.txt14
1 files changed, 14 insertions, 0 deletions
diff --git a/src/kernel/tests/CMakeLists.txt b/src/kernel/tests/CMakeLists.txt
new file mode 100644
index 0000000..e93ff9d
--- /dev/null
+++ b/src/kernel/tests/CMakeLists.txt
@@ -0,0 +1,14 @@
+cmake_minimum_required(VERSION 3.10)
+
+project(xloop-kernel-test)
+
+include_directories(${CMAKE_CURRENT_SOURCE_DIR}/include)
+include_directories(${CMAKE_CURRENT_SOURCE_DIR}/include/old)
+include_directories(${CMAKE_CURRENT_SOURCE_DIR}/..)
+
+# configure configuration config.h and add it to the include directories
+configure_file(${CMAKE_CURRENT_SOURCE_DIR}/include/config.h.in ${CMAKE_CURRENT_BINARY_DIR}/config.h)
+include_directories(${CMAKE_CURRENT_BINARY_DIR})
+
+add_subdirectory(lib)
+add_subdirectory(testcases/kernel/syscalls/ioctl)