summaryrefslogtreecommitdiffstats
path: root/src/kernel/tests/lib/CMakeLists.txt
diff options
context:
space:
mode:
authorManuel Bentele2020-10-26 11:20:41 +0100
committerManuel Bentele2020-10-26 11:20:41 +0100
commitc8dd5f0375992654814451591e97c0bab937f1a9 (patch)
tree1537f15de8e12fda482d49be2e78fedfbd3f9696 /src/kernel/tests/lib/CMakeLists.txt
parentAdd automatic generation of version and build type headers for compilation (diff)
downloadxloop-c8dd5f0375992654814451591e97c0bab937f1a9.tar.gz
xloop-c8dd5f0375992654814451591e97c0bab937f1a9.tar.xz
xloop-c8dd5f0375992654814451591e97c0bab937f1a9.zip
Remove static generation of LTP configuration header
This patch removes the static generation of the LTP configuration header done by CMake. The static generation is replaced with a fixed header (no CMake template anymore) which includes the dynamic generated xloop version header to define version number macros for LTP.
Diffstat (limited to 'src/kernel/tests/lib/CMakeLists.txt')
-rw-r--r--src/kernel/tests/lib/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/kernel/tests/lib/CMakeLists.txt b/src/kernel/tests/lib/CMakeLists.txt
index 0ce8982..5b3f421 100644
--- a/src/kernel/tests/lib/CMakeLists.txt
+++ b/src/kernel/tests/lib/CMakeLists.txt
@@ -68,3 +68,4 @@ add_library(libltp STATIC ${CMAKE_CURRENT_SOURCE_DIR}/cloner.c
${CMAKE_CURRENT_SOURCE_DIR}/tst_wallclock.c)
target_include_directories(libltp PRIVATE ${CMAKE_CURRENT_SOURCE_DIR})
target_compile_options(libltp PUBLIC "-Wno-deprecated-declarations")
+target_link_libraries(libltp LINK_PUBLIC xloop-version)