summaryrefslogtreecommitdiffstats
path: root/src/utils/sys-utils/CMakeLists.txt
diff options
context:
space:
mode:
authorManuel Bentele2020-10-23 15:18:01 +0200
committerManuel Bentele2020-10-23 15:18:01 +0200
commitdbb41ce2b7f309d394054a6bd1e33afd578798a5 (patch)
tree6a31092063d9f2fb5ac5720ec6759040e793c3d5 /src/utils/sys-utils/CMakeLists.txt
parentSet Linux kernel version to unknown if it is not detectable (diff)
downloadxloop-dbb41ce2b7f309d394054a6bd1e33afd578798a5.tar.gz
xloop-dbb41ce2b7f309d394054a6bd1e33afd578798a5.tar.xz
xloop-dbb41ce2b7f309d394054a6bd1e33afd578798a5.zip
Move the source code of all xloop components to the common 'src' directory
Diffstat (limited to 'src/utils/sys-utils/CMakeLists.txt')
-rw-r--r--src/utils/sys-utils/CMakeLists.txt19
1 files changed, 19 insertions, 0 deletions
diff --git a/src/utils/sys-utils/CMakeLists.txt b/src/utils/sys-utils/CMakeLists.txt
new file mode 100644
index 0000000..01295d9
--- /dev/null
+++ b/src/utils/sys-utils/CMakeLists.txt
@@ -0,0 +1,19 @@
+cmake_minimum_required(VERSION 3.10)
+
+# set the project name
+project(xloop-utils-sys-utils)
+
+# add xlosetup executable
+add_executable(xlosetup ${CMAKE_CURRENT_SOURCE_DIR}/xlosetup.c)
+target_link_libraries(xlosetup LINK_PUBLIC libcommon libsmartcols)
+target_include_directories(xlosetup PUBLIC ${CMAKE_CURRENT_SOURCE_DIR}/../lib ${CMAKE_CURRENT_SOURCE_DIR}/../libsmartcols)
+install(TARGETS xlosetup DESTINATION bin
+ COMPONENT main)
+
+# install xlosetup man page
+# NOTE: installation is done via a directory install with file matching pattern to support CPackRPM's automatic compression of man pages
+install(DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}/
+ DESTINATION share/man/man8
+ COMPONENT main
+ USE_SOURCE_PERMISSIONS
+ FILES_MATCHING PATTERN *.8*)